aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/gliv/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/gliv/Makefile')
-rw-r--r--graphics/gliv/Makefile14
1 files changed, 5 insertions, 9 deletions
diff --git a/graphics/gliv/Makefile b/graphics/gliv/Makefile
index 2cbf9e0aadf1..8fdcc3a83a79 100644
--- a/graphics/gliv/Makefile
+++ b/graphics/gliv/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= gliv
-PORTVERSION= 1.7.1
+PORTVERSION= 1.8
CATEGORIES= graphics
MASTER_SITES= http://gliv.tuxfamily.org/
@@ -14,22 +14,18 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= An image viewer that uses Gdk-Pixbuf and OpenGL
LIB_DEPENDS= gtkglext-x11-1.0.2:${PORTSDIR}/x11-toolkits/gtkglext
-RUN_DEPENDS= ${LOCALBASE}/bin/convert:${PORTSDIR}/graphics/ImageMagick
USE_BZIP2= yes
USE_X_PREFIX= yes
-USE_REINPLACE= yes
+USE_GL= yes
USE_GETOPT_LONG= yes
+USE_GNOME= gnomehack gnometarget gtk20
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
MAN1= gliv.1
-CPPFLAGS= -I${LOCALBASE}/include -I${X11BASE}/include ${PTHREAD_CFLAGS}
-LDFLAGS= -L${LOCALBASE}/lib -L${X11BASE}/lib -lXext -lX11 ${PTHREAD_LIBS}
-
-post-patch:
- @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g' ${WRKSRC}/configure
+CPPFLAGS= -I${LOCALBASE}/include
+LDFLAGS= -L${LOCALBASE}/lib
.include <bsd.port.mk>