aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/gthumb/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/gthumb/Makefile')
-rw-r--r--graphics/gthumb/Makefile12
1 files changed, 3 insertions, 9 deletions
diff --git a/graphics/gthumb/Makefile b/graphics/gthumb/Makefile
index 9daed793d800..0a79e99c165b 100644
--- a/graphics/gthumb/Makefile
+++ b/graphics/gthumb/Makefile
@@ -3,8 +3,7 @@
# $MCom: ports/trunk/graphics/gthumb/Makefile 19823 2014-08-20 09:28:14Z gusi $
PORTNAME= gthumb
-PORTVERSION= 3.4.3
-PORTREVISION= 1
+PORTVERSION= 3.4.4.1
CATEGORIES= graphics
MASTER_SITES= GNOME
DIST_SUBDIR= gnome3
@@ -19,7 +18,7 @@ BUILD_DEPENDS= gsettings-desktop-schemas>0:devel/gsettings-desktop-schemas \
RUN_DEPENDS= gsettings-desktop-schemas>0:devel/gsettings-desktop-schemas
USES= bison compiler:c++11-lib desktop-file-utils gettext gmake \
- libtool pathfix pkgconfig tar:xz
+ libtool localbase pathfix pkgconfig tar:xz
USE_GNOME= gtk30 intltool librsvg2
GNU_CONFIGURE= yes
CONFIGURE_ENV= ac_cv_lib_jpeg_jpeg_destroy_decompress=yes \
@@ -31,9 +30,6 @@ INSTALL_TARGET= install-strip
USE_LDCONFIG= yes
INSTALLS_ICONS= yes
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
-
PLIST_SUB= GTHUMB_VER="3.4"
GLIB_SCHEMAS= org.gnome.gthumb.change-date.gschema.xml \
@@ -94,8 +90,6 @@ YELP_DESC= Viewer for built-in help system
YELP_RUN_DEPENDS= yelp:x11/yelp
post-patch:
- @${REINPLACE_CMD} -e \
- 's|-Wl,--as-needed|| ; \
- /^[[:blank:]]zlib/d' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|-Wl,--as-needed||' ${WRKSRC}/configure
.include <bsd.port.mk>