aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/libdrm/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/libdrm/Makefile')
-rw-r--r--graphics/libdrm/Makefile24
1 files changed, 20 insertions, 4 deletions
diff --git a/graphics/libdrm/Makefile b/graphics/libdrm/Makefile
index a5d6fe96e8f5..aa550204d9e6 100644
--- a/graphics/libdrm/Makefile
+++ b/graphics/libdrm/Makefile
@@ -2,7 +2,8 @@
# $FreeBSD$
PORTNAME= libdrm
-PORTVERSION= 2.4.66
+PORTVERSION= 2.4.74
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= graphics x11
MASTER_SITES= http://dri.freedesktop.org/libdrm/
@@ -10,7 +11,11 @@ MASTER_SITES= http://dri.freedesktop.org/libdrm/
MAINTAINER= x11@FreeBSD.org
COMMENT= Userspace interface to kernel Direct Rendering Module services
+LICENSE= MIT
+
+BUILD_DEPENDS= libdevq>=0.0.4:devel/libdevq
LIB_DEPENDS= libpciaccess.so:devel/libpciaccess \
+ libdevq.so:devel/libdevq \
libpthread-stubs.so:devel/libpthread-stubs
USES= libtool pkgconfig tar:bzip2
@@ -31,10 +36,10 @@ USES+= gmake
# KMS support in the kernel is only build on these archs, disable others
.if ${ARCH} == "amd64" || ${ARCH} == "i386"
CONFIGURE_ARGS+=--enable-libkms
-PLIST_SUB+= KMS="" NOUVEAU=""
+PLIST_SUB+= KMS=""
.else
CONFIGURE_ARGS+=--disable-libkms
-PLIST_SUB+= KMS="@comment " NOUVEAU="@comment "
+PLIST_SUB+= KMS="@comment "
.endif
.if ${PORT_OPTIONS:MMANPAGES}
@@ -49,13 +54,24 @@ PLIST_SUB+= MAN="@comment "
CONFIGURE_ARGS+=--disable-vmwgfx
.if ${ARCH} == amd64 || ${ARCH} == i386
+PLIST_SUB+= ARM_DRIVERS="@comment "
PLIST_SUB+= INTEL_DRIVER=""
+PLIST_SUB+= NOUVEAU_DRIVER=""
PLIST_SUB+= RADEON_DRIVERS=""
-.elif ${ARCH} == ia64 || ${ARCH} == powerpc || ${ARCH} == powerpc64
+.elif ${ARCH} == powerpc || ${ARCH} == powerpc64
+PLIST_SUB+= ARM_DRIVERS="@comment "
PLIST_SUB+= INTEL_DRIVER="@comment "
+PLIST_SUB+= NOUVEAU_DRIVER=""
PLIST_SUB+= RADEON_DRIVERS=""
+.elif ${ARCH} == armv6 || ${ARCH} == aarch64
+PLIST_SUB+= ARM_DRIVERS=""
+PLIST_SUB+= INTEL_DRIVER="@comment "
+PLIST_SUB+= NOUVEAU_DRIVER="@comment "
+PLIST_SUB+= RADEON_DRIVERS="@comment "
.else
+PLIST_SUB+= ARM_DRIVERS="@comment "
PLIST_SUB+= INTEL_DRIVER="@comment "
+PLIST_SUB+= NOUVEAU_DRIVER="@comment "
PLIST_SUB+= RADEON_DRIVERS="@comment "
.endif