aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/libjpeg-turbo/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/libjpeg-turbo/Makefile')
-rw-r--r--graphics/libjpeg-turbo/Makefile8
1 files changed, 8 insertions, 0 deletions
diff --git a/graphics/libjpeg-turbo/Makefile b/graphics/libjpeg-turbo/Makefile
index fdbcc3cdb75b..84c0a2de1291 100644
--- a/graphics/libjpeg-turbo/Makefile
+++ b/graphics/libjpeg-turbo/Makefile
@@ -32,4 +32,12 @@ PLIST_SUB= SOVERSION=${SOVERSION}
# chase graphics/jpeg
SOVERSION= 11
+OPTIONS+= PIC "Static library with PIC (required for VirtualGL)" off
+
+.include <bsd.port.options.mk>
+
+.if defined(WITH_PIC)
+CONFIGURE_ARGS+=--with-pic
+.endif
+
.include <bsd.port.mk>