aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/mplayer/files/get-feat
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/mplayer/files/get-feat')
-rw-r--r--graphics/mplayer/files/get-feat18
1 files changed, 18 insertions, 0 deletions
diff --git a/graphics/mplayer/files/get-feat b/graphics/mplayer/files/get-feat
new file mode 100644
index 000000000000..07deea5e6107
--- /dev/null
+++ b/graphics/mplayer/files/get-feat
@@ -0,0 +1,18 @@
+#This perl script will determine the supported CPU features
+#of this machine, so the build of the correct decode plugins
+#will do automatically
+
+@list=`cat /var/run/dmesg.boot|grep Feat`;
+@features=("MMX","SSE","3DNow!","DSP");
+open (INC,">$ENV{TEMPDIR}/Makefile.inc");
+foreach $feature(@features)
+{
+ foreach $line(@list)
+ {
+ if ( $line =~ m/$feature/)
+ {
+ print INC "WITH_$feature = yes\n";
+ }
+ }
+}
+close (INC);