aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/osg-devel
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/osg-devel')
-rw-r--r--graphics/osg-devel/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/graphics/osg-devel/Makefile b/graphics/osg-devel/Makefile
index d010395ab42a..8f7d3f7633f3 100644
--- a/graphics/osg-devel/Makefile
+++ b/graphics/osg-devel/Makefile
@@ -210,8 +210,8 @@ USE_XORG+= xrandr
post-patch:
@${FIND} ${WRKSRC}/CMakeModules -type f -print0 | ${XARGS} -0 \
${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|g'
- @${REINPLACE_CMD} -e '/FIND_LIBRARY.*DL_LIBRARY/ d' \
- ${WRKSRC}/CMakeLists.txt
+ @${REINPLACE_CMD} -e '/FIND_LIBRARY.*DL_LIBRARY/ d; \
+ s|-pedantic||' ${WRKSRC}/CMakeLists.txt
.for p in ${FORCE_REQUIRE}
@${REINPLACE_CMD} -e '/FIND_PACKAGE.*${p}/ s|)$$| REQUIRED&|' \
${WRKSRC}/CMakeLists.txt