aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/osg/pkg-plist
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/osg/pkg-plist')
-rw-r--r--graphics/osg/pkg-plist142
1 files changed, 126 insertions, 16 deletions
diff --git a/graphics/osg/pkg-plist b/graphics/osg/pkg-plist
index 072228684a24..ec6257070ace 100644
--- a/graphics/osg/pkg-plist
+++ b/graphics/osg/pkg-plist
@@ -3,6 +3,7 @@ bin/osgconv
bin/osgfilecache
bin/osgversion
bin/osgviewer
+bin/present3D
include/OpenThreads/Atomic
include/OpenThreads/Barrier
include/OpenThreads/Block
@@ -20,6 +21,8 @@ include/osg/AnimationPath
include/osg/ApplicationUsage
include/osg/ArgumentParser
include/osg/Array
+include/osg/ArrayDispatchers
+include/osg/AudioStream
include/osg/AutoTransform
include/osg/Billboard
include/osg/BlendColor
@@ -28,6 +31,7 @@ include/osg/BlendFunc
include/osg/BoundingBox
include/osg/BoundingSphere
include/osg/BoundsChecking
+include/osg/BufferIndexBinding
include/osg/BufferObject
include/osg/Camera
include/osg/CameraNode
@@ -64,12 +68,14 @@ include/osg/FrameStamp
include/osg/FrontFace
include/osg/GL
include/osg/GL2Extensions
+include/osg/GLBeginEndAdapter
include/osg/GLExtensions
include/osg/GLObjects
include/osg/GLU
include/osg/Geode
include/osg/Geometry
include/osg/GraphicsContext
+include/osg/GraphicsCostEstimator
include/osg/GraphicsThread
include/osg/Group
include/osg/Hint
@@ -100,6 +106,8 @@ include/osg/NodeTrackerCallback
include/osg/NodeVisitor
include/osg/Notify
include/osg/Object
+include/osg/Observer
+include/osg/ObserverNodePath
include/osg/OccluderNode
include/osg/OcclusionQueryNode
include/osg/OperationThread
@@ -123,11 +131,14 @@ include/osg/Scissor
include/osg/Sequence
include/osg/ShadeModel
include/osg/Shader
+include/osg/ShaderAttribute
+include/osg/ShaderComposer
include/osg/ShadowVolumeOccluder
include/osg/Shape
include/osg/ShapeDrawable
include/osg/State
include/osg/StateAttribute
+include/osg/StateAttributeCallback
include/osg/StateSet
include/osg/Stats
include/osg/Stencil
@@ -144,6 +155,7 @@ include/osg/Texture
include/osg/Texture1D
include/osg/Texture2D
include/osg/Texture2DArray
+include/osg/Texture2DMultisample
include/osg/Texture3D
include/osg/TextureCubeMap
include/osg/TextureRectangle
@@ -153,6 +165,8 @@ include/osg/Transform
include/osg/TriangleFunctor
include/osg/TriangleIndexFunctor
include/osg/Uniform
+include/osg/UserDataContainer
+include/osg/ValueObject
include/osg/Vec2
include/osg/Vec2b
include/osg/Vec2d
@@ -178,45 +192,74 @@ include/osg/fast_back_stack
include/osg/io_utils
include/osg/observer_ptr
include/osg/ref_ptr
+include/osgAnimation/Action
+include/osgAnimation/ActionAnimation
+include/osgAnimation/ActionBlendIn
+include/osgAnimation/ActionBlendOut
+include/osgAnimation/ActionCallback
+include/osgAnimation/ActionStripAnimation
+include/osgAnimation/ActionVisitor
include/osgAnimation/Animation
include/osgAnimation/AnimationManagerBase
-include/osgAnimation/Assert
+include/osgAnimation/AnimationUpdateCallback
include/osgAnimation/BasicAnimationManager
include/osgAnimation/Bone
+include/osgAnimation/BoneMapVisitor
include/osgAnimation/Channel
include/osgAnimation/CubicBezier
include/osgAnimation/EaseMotion
include/osgAnimation/Export
+include/osgAnimation/FrameAction
include/osgAnimation/Interpolator
include/osgAnimation/Keyframe
include/osgAnimation/LinkVisitor
+include/osgAnimation/MorphGeometry
include/osgAnimation/RigGeometry
+include/osgAnimation/RigTransform
+include/osgAnimation/RigTransformHardware
+include/osgAnimation/RigTransformSoftware
include/osgAnimation/Sampler
include/osgAnimation/Skeleton
-include/osgAnimation/Skinning
+include/osgAnimation/StackedMatrixElement
+include/osgAnimation/StackedQuaternionElement
+include/osgAnimation/StackedRotateAxisElement
+include/osgAnimation/StackedScaleElement
+include/osgAnimation/StackedTransform
+include/osgAnimation/StackedTransformElement
+include/osgAnimation/StackedTranslateElement
+include/osgAnimation/StatsHandler
+include/osgAnimation/StatsVisitor
include/osgAnimation/Target
include/osgAnimation/Timeline
include/osgAnimation/TimelineAnimationManager
-include/osgAnimation/UpdateCallback
+include/osgAnimation/UpdateBone
+include/osgAnimation/UpdateMaterial
+include/osgAnimation/UpdateMatrixTransform
include/osgAnimation/Vec3Packed
include/osgAnimation/VertexInfluence
include/osgDB/Archive
include/osgDB/AuthenticationMap
+include/osgDB/Callbacks
include/osgDB/ConvertUTF
+include/osgDB/DataTypes
include/osgDB/DatabasePager
+include/osgDB/DatabaseRevisions
include/osgDB/DotOsgWrapper
include/osgDB/DynamicLibrary
include/osgDB/Export
-include/osgDB/Field
-include/osgDB/FieldReader
-include/osgDB/FieldReaderIterator
+include/osgDB/ExternalFileWriter
include/osgDB/FileCache
include/osgDB/FileNameUtils
include/osgDB/FileUtils
include/osgDB/ImageOptions
include/osgDB/ImagePager
+include/osgDB/ImageProcessor
include/osgDB/Input
+include/osgDB/InputStream
+include/osgDB/ObjectWrapper
+include/osgDB/Options
include/osgDB/Output
+include/osgDB/OutputStream
include/osgDB/ParameterOutput
include/osgDB/PluginQuery
include/osgDB/ReadFile
@@ -224,8 +267,10 @@ include/osgDB/ReaderWriter
include/osgDB/Registry
include/osgDB/Serializer
include/osgDB/SharedStateManager
+include/osgDB/StreamOperator
include/osgDB/Version
include/osgDB/WriteFile
+include/osgDB/XmlParser
include/osgDB/fstream
include/osgFX/AnisotropicLighting
include/osgFX/BumpMapping
@@ -233,6 +278,7 @@ include/osgFX/Cartoon
include/osgFX/Effect
include/osgFX/Export
include/osgFX/MultiTextureControl
+include/osgFX/Outline
include/osgFX/Registry
include/osgFX/Scribe
include/osgFX/SpecularHighlights
@@ -240,18 +286,23 @@ include/osgFX/Technique
include/osgFX/Validator
include/osgFX/Version
include/osgGA/AnimationPathManipulator
+include/osgGA/CameraManipulator
include/osgGA/CameraViewSwitchManipulator
include/osgGA/DriveManipulator
include/osgGA/EventQueue
include/osgGA/EventVisitor
include/osgGA/Export
+include/osgGA/FirstPersonManipulator
include/osgGA/FlightManipulator
include/osgGA/GUIActionAdapter
include/osgGA/GUIEventAdapter
include/osgGA/GUIEventHandler
include/osgGA/KeySwitchMatrixManipulator
-include/osgGA/MatrixManipulator
+include/osgGA/MultiTouchTrackballManipulator
include/osgGA/NodeTrackerManipulator
+include/osgGA/OrbitManipulator
+include/osgGA/SphericalManipulator
+include/osgGA/StandardManipulator
include/osgGA/StateSetManipulator
include/osgGA/TerrainManipulator
include/osgGA/TrackballManipulator
@@ -271,6 +322,7 @@ include/osgManipulator/Scale2DDragger
include/osgManipulator/ScaleAxisDragger
include/osgManipulator/Selection
include/osgManipulator/TabBoxDragger
+include/osgManipulator/TabBoxTrackballDragger
include/osgManipulator/TabPlaneDragger
include/osgManipulator/TabPlaneTrackballDragger
include/osgManipulator/TrackballDragger
@@ -281,14 +333,20 @@ include/osgManipulator/TranslatePlaneDragger
include/osgManipulator/Version
include/osgParticle/AccelOperator
include/osgParticle/AngularAccelOperator
+include/osgParticle/AngularDampingOperator
+include/osgParticle/BounceOperator
include/osgParticle/BoxPlacer
include/osgParticle/CenteredPlacer
+include/osgParticle/CompositePlacer
include/osgParticle/ConnectedParticleSystem
include/osgParticle/ConstantRateCounter
include/osgParticle/Counter
+include/osgParticle/DampingOperator
+include/osgParticle/DomainOperator
include/osgParticle/Emitter
include/osgParticle/ExplosionDebrisEffect
include/osgParticle/ExplosionEffect
+include/osgParticle/ExplosionOperator
include/osgParticle/Export
include/osgParticle/FireEffect
include/osgParticle/FluidFrictionOperator
@@ -300,6 +358,7 @@ include/osgParticle/ModularEmitter
include/osgParticle/ModularProgram
include/osgParticle/MultiSegmentPlacer
include/osgParticle/Operator
+include/osgParticle/OrbitOperator
include/osgParticle/Particle
include/osgParticle/ParticleEffect
include/osgParticle/ParticleProcessor
@@ -314,11 +373,18 @@ include/osgParticle/RandomRateCounter
include/osgParticle/SectorPlacer
include/osgParticle/SegmentPlacer
include/osgParticle/Shooter
+include/osgParticle/SinkOperator
include/osgParticle/SmokeEffect
include/osgParticle/SmokeTrailEffect
include/osgParticle/VariableRateCounter
include/osgParticle/Version
include/osgParticle/range
+include/osgPresentation/AnimationMaterial
+include/osgPresentation/CompileSlideCallback
+include/osgPresentation/Export
+include/osgPresentation/PickEventHandler
+include/osgPresentation/SlideEventHandler
+include/osgPresentation/SlideShowConstructor
include/osgShadow/ConvexPolyhedron
include/osgShadow/DebugShadowMap
include/osgShadow/Export
@@ -375,8 +441,10 @@ include/osgText/Export
include/osgText/FadeText
include/osgText/Font
include/osgText/Font3D
+include/osgText/Glyph
include/osgText/KerningType
include/osgText/String
+include/osgText/Style
include/osgText/Text
include/osgText/Text3D
include/osgText/TextBase
@@ -392,14 +460,17 @@ include/osgUtil/Export
include/osgUtil/GLObjectsVisitor
include/osgUtil/HalfWayMapGenerator
include/osgUtil/HighlightMapGenerator
+include/osgUtil/IncrementalCompileOperation
include/osgUtil/IntersectVisitor
include/osgUtil/IntersectionVisitor
include/osgUtil/LineSegmentIntersector
+include/osgUtil/MeshOptimizers
include/osgUtil/OperationArrayFunctor
include/osgUtil/Optimizer
include/osgUtil/PlaneIntersector
include/osgUtil/PolytopeIntersector
include/osgUtil/PositionalStateContainer
+include/osgUtil/PrintVisitor
include/osgUtil/ReflectionMapGenerator
include/osgUtil/RenderBin
include/osgUtil/RenderLeaf
@@ -407,6 +478,7 @@ include/osgUtil/RenderStage
include/osgUtil/ReversePrimitiveFunctor
include/osgUtil/SceneGraphBuilder
include/osgUtil/SceneView
+include/osgUtil/ShaderGen
include/osgUtil/Simplifier
include/osgUtil/SmoothingVisitor
include/osgUtil/StateGraph
@@ -421,8 +493,6 @@ include/osgUtil/Version
include/osgViewer/CompositeViewer
include/osgViewer/Export
include/osgViewer/GraphicsWindow
-include/osgViewer/GraphicsWindowX11
-include/osgViewer/PixelBufferX11
include/osgViewer/Renderer
include/osgViewer/Scene
include/osgViewer/Version
@@ -430,6 +500,7 @@ include/osgViewer/View
include/osgViewer/Viewer
include/osgViewer/ViewerBase
include/osgViewer/ViewerEventHandlers
+include/osgViewer/api/X11/GraphicsHandleX11
include/osgViewer/api/X11/GraphicsWindowX11
include/osgViewer/api/X11/PixelBufferX11
include/osgVolume/Export
@@ -490,6 +561,9 @@ lib/libosgManipulator.so.%%OSG_SHLIBVER%%
lib/libosgParticle.so
lib/libosgParticle.so.%%OSG_VERSION%%
lib/libosgParticle.so.%%OSG_SHLIBVER%%
+lib/libosgPresentation.so
+lib/libosgPresentation.so.%%OSG_VERSION%%
+lib/libosgPresentation.so.%%OSG_SHLIBVER%%
lib/libosgShadow.so
lib/libosgShadow.so.%%OSG_VERSION%%
lib/libosgShadow.so.%%OSG_SHLIBVER%%
@@ -523,11 +597,23 @@ lib/osgPlugins-%%OSG_VERSION%%/osgdb_bvh.so
lib/osgPlugins-%%OSG_VERSION%%/osgdb_cfg.so
%%CURL%%lib/osgPlugins-%%OSG_VERSION%%/osgdb_curl.so
lib/osgPlugins-%%OSG_VERSION%%/osgdb_dds.so
+lib/osgPlugins-%%OSG_VERSION%%/osgdb_deprecated_osg.so
+lib/osgPlugins-%%OSG_VERSION%%/osgdb_deprecated_osganimation.so
+lib/osgPlugins-%%OSG_VERSION%%/osgdb_deprecated_osgfx.so
+lib/osgPlugins-%%OSG_VERSION%%/osgdb_deprecated_osgparticle.so
+lib/osgPlugins-%%OSG_VERSION%%/osgdb_deprecated_osgshadow.so
+lib/osgPlugins-%%OSG_VERSION%%/osgdb_deprecated_osgsim.so
+lib/osgPlugins-%%OSG_VERSION%%/osgdb_deprecated_osgterrain.so
+lib/osgPlugins-%%OSG_VERSION%%/osgdb_deprecated_osgtext.so
+lib/osgPlugins-%%OSG_VERSION%%/osgdb_deprecated_osgviewer.so
+lib/osgPlugins-%%OSG_VERSION%%/osgdb_deprecated_osgvolume.so
+lib/osgPlugins-%%OSG_VERSION%%/osgdb_deprecated_osgwidget.so
%%ITK%%lib/osgPlugins-%%OSG_VERSION%%/osgdb_dicom.so
lib/osgPlugins-%%OSG_VERSION%%/osgdb_dot.so
lib/osgPlugins-%%OSG_VERSION%%/osgdb_dw.so
lib/osgPlugins-%%OSG_VERSION%%/osgdb_dxf.so
%%OPENEXR%%lib/osgPlugins-%%OSG_VERSION%%/osgdb_exr.so
+%%FFMPEG%%lib/osgPlugins-%%OSG_VERSION%%/osgdb_ffmpeg.so
%%FREETYPE%%lib/osgPlugins-%%OSG_VERSION%%/osgdb_freetype.so
%%GDAL%%lib/osgPlugins-%%OSG_VERSION%%/osgdb_gdal.so
lib/osgPlugins-%%OSG_VERSION%%/osgdb_geo.so
@@ -550,24 +636,32 @@ lib/osgPlugins-%%OSG_VERSION%%/osgdb_obj.so
lib/osgPlugins-%%OSG_VERSION%%/osgdb_openflight.so
lib/osgPlugins-%%OSG_VERSION%%/osgdb_osg.so
lib/osgPlugins-%%OSG_VERSION%%/osgdb_osga.so
-lib/osgPlugins-%%OSG_VERSION%%/osgdb_osganimation.so
-lib/osgPlugins-%%OSG_VERSION%%/osgdb_osgfx.so
-lib/osgPlugins-%%OSG_VERSION%%/osgdb_osgparticle.so
lib/osgPlugins-%%OSG_VERSION%%/osgdb_osgshadow.so
-lib/osgPlugins-%%OSG_VERSION%%/osgdb_osgsim.so
lib/osgPlugins-%%OSG_VERSION%%/osgdb_osgterrain.so
-lib/osgPlugins-%%OSG_VERSION%%/osgdb_osgtext.so
lib/osgPlugins-%%OSG_VERSION%%/osgdb_osgtgz.so
lib/osgPlugins-%%OSG_VERSION%%/osgdb_osgviewer.so
-lib/osgPlugins-%%OSG_VERSION%%/osgdb_osgvolume.so
-lib/osgPlugins-%%OSG_VERSION%%/osgdb_osgwidget.so
+lib/osgPlugins-%%OSG_VERSION%%/osgdb_p3d.so
%%PDF%%lib/osgPlugins-%%OSG_VERSION%%/osgdb_pdf.so
lib/osgPlugins-%%OSG_VERSION%%/osgdb_pic.so
+lib/osgPlugins-%%OSG_VERSION%%/osgdb_ply.so
lib/osgPlugins-%%OSG_VERSION%%/osgdb_png.so
lib/osgPlugins-%%OSG_VERSION%%/osgdb_pnm.so
+lib/osgPlugins-%%OSG_VERSION%%/osgdb_pov.so
+lib/osgPlugins-%%OSG_VERSION%%/osgdb_pvr.so
+lib/osgPlugins-%%OSG_VERSION%%/osgdb_revisions.so
lib/osgPlugins-%%OSG_VERSION%%/osgdb_rgb.so
lib/osgPlugins-%%OSG_VERSION%%/osgdb_rot.so
lib/osgPlugins-%%OSG_VERSION%%/osgdb_scale.so
+lib/osgPlugins-%%OSG_VERSION%%/osgdb_serializers_osg.so
+lib/osgPlugins-%%OSG_VERSION%%/osgdb_serializers_osganimation.so
+lib/osgPlugins-%%OSG_VERSION%%/osgdb_serializers_osgfx.so
+lib/osgPlugins-%%OSG_VERSION%%/osgdb_serializers_osgmanipulator.so
+lib/osgPlugins-%%OSG_VERSION%%/osgdb_serializers_osgparticle.so
+lib/osgPlugins-%%OSG_VERSION%%/osgdb_serializers_osgshadow.so
+lib/osgPlugins-%%OSG_VERSION%%/osgdb_serializers_osgsim.so
+lib/osgPlugins-%%OSG_VERSION%%/osgdb_serializers_osgterrain.so
+lib/osgPlugins-%%OSG_VERSION%%/osgdb_serializers_osgtext.so
+lib/osgPlugins-%%OSG_VERSION%%/osgdb_serializers_osgvolume.so
lib/osgPlugins-%%OSG_VERSION%%/osgdb_shp.so
lib/osgPlugins-%%OSG_VERSION%%/osgdb_stl.so
%%SVG%%lib/osgPlugins-%%OSG_VERSION%%/osgdb_svg.so
@@ -583,6 +677,21 @@ lib/osgPlugins-%%OSG_VERSION%%/osgdb_vtf.so
lib/osgPlugins-%%OSG_VERSION%%/osgdb_x.so
%%XINE%%lib/osgPlugins-%%OSG_VERSION%%/osgdb_xine.so
lib/osgPlugins-%%OSG_VERSION%%/osgdb_zip.so
+libdata/pkgconfig/openscenegraph-osg.pc
+libdata/pkgconfig/openscenegraph-osgAnimation.pc
+libdata/pkgconfig/openscenegraph-osgDB.pc
+libdata/pkgconfig/openscenegraph-osgFX.pc
+libdata/pkgconfig/openscenegraph-osgGA.pc
+libdata/pkgconfig/openscenegraph-osgManipulator.pc
+libdata/pkgconfig/openscenegraph-osgParticle.pc
+libdata/pkgconfig/openscenegraph-osgShadow.pc
+libdata/pkgconfig/openscenegraph-osgSim.pc
+libdata/pkgconfig/openscenegraph-osgTerrain.pc
+libdata/pkgconfig/openscenegraph-osgText.pc
+libdata/pkgconfig/openscenegraph-osgUtil.pc
+libdata/pkgconfig/openscenegraph-osgViewer.pc
+libdata/pkgconfig/openscenegraph-osgVolume.pc
+libdata/pkgconfig/openscenegraph-osgWidget.pc
libdata/pkgconfig/openscenegraph.pc
libdata/pkgconfig/openthreads.pc
@dirrm lib/osgPlugins-%%OSG_VERSION%%
@@ -596,6 +705,7 @@ libdata/pkgconfig/openthreads.pc
@dirrm include/osgTerrain
@dirrm include/osgSim
@dirrm include/osgShadow
+@dirrm include/osgPresentation
@dirrm include/osgParticle
@dirrm include/osgManipulator
@dirrm include/osgGA