aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/py-img2pdf
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/py-img2pdf')
-rw-r--r--graphics/py-img2pdf/Makefile14
1 files changed, 11 insertions, 3 deletions
diff --git a/graphics/py-img2pdf/Makefile b/graphics/py-img2pdf/Makefile
index 4c78789c1f45..0264339bcb91 100644
--- a/graphics/py-img2pdf/Makefile
+++ b/graphics/py-img2pdf/Makefile
@@ -2,6 +2,7 @@
PORTNAME= img2pdf
DISTVERSION= 0.3.3
+PORTREVISION= 1
CATEGORIES= graphics python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -12,8 +13,7 @@ COMMENT= Convert images to PDF via direct JPEG inclusion
LICENSE= LGPL3+
LICENSE_FILE= ${WRKSRC}/LICENSE
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pillow>0:graphics/py-pillow@${PY_FLAVOR} \
- ${PY_ENUM34}
+RUN_DEPENDS= ${PY_ENUM34}
TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pdfrw>0:textproc/py-pdfrw@${PY_FLAVOR}
USES= python
@@ -21,9 +21,17 @@ USE_PYTHON= autoplist concurrent distutils
NO_ARCH= yes
+.include <bsd.port.pre.mk>
+
+.if ${PYTHON_REL} < 3500
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}pillow6>0:graphics/py-pillow6@${PY_FLAVOR}
+.else
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}pillow>0:graphics/py-pillow@${PY_FLAVOR}
+.endif
+
# Note: The tests only work with Python 3, see also:
# https://gitlab.mister-muffin.de/josch/img2pdf/issues/60
do-test:
@(cd ${WRKSRC} && ${PYTHON_CMD} ${PYDISTUTILS_SETUP} test)
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>