aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/py-pillow/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/py-pillow/Makefile')
-rw-r--r--graphics/py-pillow/Makefile8
1 files changed, 5 insertions, 3 deletions
diff --git a/graphics/py-pillow/Makefile b/graphics/py-pillow/Makefile
index 5a2700cd5b24..6051e421d28b 100644
--- a/graphics/py-pillow/Makefile
+++ b/graphics/py-pillow/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= pillow
-PORTVERSION= 6.2.2
+PORTVERSION= 7.0.0
CATEGORIES= graphics python
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -17,14 +17,16 @@ LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>0:devel/py-pytest@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pytest-runner>0:devel/py-pytest-runner@${PY_FLAVOR}
-# Python 2.7,3.5+
-USES= cpe python
+# Python 3.5+
+USES= cpe python:3.5+
USE_GITHUB= yes
USE_PYTHON= autoplist concurrent distutils
GH_ACCOUNT= python-${PORTNAME}
GH_PROJECT= ${PORTNAME:C/p/P/}
+CONFLICTS_INSTALL= ${PYTHON_PKGNAMEPREFIX}pillow6
+
OPTIONS_DEFINE= FREETYPE JPEG JPEG2000 LCMS OLE PNG TIFF TKINTER WEBP
OPTIONS_DEFAULT= FREETYPE JPEG JPEG2000 LCMS OLE PNG TIFF TKINTER WEBP