aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/synaesthesia/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/synaesthesia/Makefile')
-rw-r--r--graphics/synaesthesia/Makefile9
1 files changed, 6 insertions, 3 deletions
diff --git a/graphics/synaesthesia/Makefile b/graphics/synaesthesia/Makefile
index 0a4d552bbe6f..1d84f84518b5 100644
--- a/graphics/synaesthesia/Makefile
+++ b/graphics/synaesthesia/Makefile
@@ -10,14 +10,15 @@ MASTER_SITES= http://www.logarithmic.net/pfh-files/synaesthesia/
MAINTAINER= ports@FreeBSD.org
COMMENT= Real-time graphical music representation program
-LICENSE= GPLv2
+LICENSE= GPLv2+
+LICENSE_FILE= ${WRKSRC}/COPYING
USES= alias gmake
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-sdl-prefix=${LOCALBASE}
USE_SDL= sdl
-PORTDOCS= README
+PORTDOCS= *
PLIST_FILES= bin/${PORTNAME}
OPTIONS_DEFINE= DOCS
@@ -28,7 +29,9 @@ post-patch:
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
+
+do-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
- ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>