aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/xfractint/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/xfractint/Makefile')
-rw-r--r--graphics/xfractint/Makefile30
1 files changed, 17 insertions, 13 deletions
diff --git a/graphics/xfractint/Makefile b/graphics/xfractint/Makefile
index 10241762ad52..b06270efd72e 100644
--- a/graphics/xfractint/Makefile
+++ b/graphics/xfractint/Makefile
@@ -2,32 +2,36 @@
# $FreeBSD$
PORTNAME= xfractint
-PORTVERSION= 20.04p12
-PORTREVISION= 1
+PORTVERSION= 20.04p14
CATEGORIES= graphics
-MASTER_SITES= http://www.fractint.org/ftp/current/linux/ \
+MASTER_SITES= http://www.fractint.org/ftp/current/linux/ \
http://twegner.dyndns.org/fractint/ftp/current/linux/
MAINTAINER= onemda@gmail.com
-COMMENT= The Unix port of fractint
-
-BROKEN= No public distfiles
+COMMENT= Unix port of FractInt
USES= gmake
USE_XORG= x11 xft
ALL_TARGET= ${PORTNAME}
-DESKTOP_ENTRIES+="Xfracint" "${COMMENT}" "" "${PORTNAME}" "" "false"
+DESKTOP_ENTRIES= "Xfracint" "${COMMENT}" "" "${PORTNAME}" "" "false"
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 1000034
+EXTRA_PATCHES= ${FILESDIR}/pre-1000034-libm-patch
+.endif
do-install:
- @${INSTALL_PROGRAM} ${WRKSRC}/xfractint ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
- @${INSTALL_MAN} ${WRKSRC}/unix/xfractint.man ${STAGEDIR}${PREFIX}/man/man1/${MAN1}
+ ${INSTALL_PROGRAM} ${WRKSRC}/xfractint ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/unix/xfractint.man \
+ ${STAGEDIR}${MANPREFIX}/man/man1/xfractint.1
@${MKDIR} ${STAGEDIR}${DATADIR}
- @${INSTALL_DATA} ${WRKSRC}/fractint.hlp ${STAGEDIR}${DATADIR}
- @${INSTALL_DATA} ${WRKSRC}/sstools.ini ${STAGEDIR}${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/fractint.hlp ${STAGEDIR}${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/sstools.ini ${STAGEDIR}${DATADIR}
.for dir in formulas ifs lsystem maps pars
- @cd ${WRKSRC} && ${COPYTREE_SHARE} ${dir} ${STAGEDIR}${DATADIR}
+ cd ${WRKSRC} && ${COPYTREE_SHARE} ${dir} ${STAGEDIR}${DATADIR}
.endfor
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>