aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
Diffstat (limited to 'graphics')
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/transcode/Makefile83
-rw-r--r--graphics/transcode/distinfo1
-rw-r--r--graphics/transcode/files/patch-aa34
-rw-r--r--graphics/transcode/files/patch-ab10
-rw-r--r--graphics/transcode/files/patch-ac14
-rw-r--r--graphics/transcode/files/patch-ad44
-rw-r--r--graphics/transcode/files/patch-ae10
-rw-r--r--graphics/transcode/files/patch-af19
-rw-r--r--graphics/transcode/files/patch-ag11
-rw-r--r--graphics/transcode/pkg-comment1
-rw-r--r--graphics/transcode/pkg-descr13
-rw-r--r--graphics/transcode/pkg-plist78
13 files changed, 319 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index 7b665a3d139f..d14e585966f0 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -316,6 +316,7 @@
SUBDIR += tifmerge
SUBDIR += tkxanim
SUBDIR += togl
+ SUBDIR += transcode
SUBDIR += truevision
SUBDIR += twinlib
SUBDIR += txtmerge
diff --git a/graphics/transcode/Makefile b/graphics/transcode/Makefile
new file mode 100644
index 000000000000..36cb71fe9cce
--- /dev/null
+++ b/graphics/transcode/Makefile
@@ -0,0 +1,83 @@
+# New ports collection makefile for: transcode
+# Date created: 17 December 2001
+# Whom: Hendrik Scholz <hendrik@scholz.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= transcode
+PORTVERSION= 0.6.0
+PORTREVISION= 1
+CATEGORIES= graphics
+MASTER_SITES= http://www.theorie.physik.uni-goettingen.de/~ostreich/transcode/pre/
+DISTNAME= ${PORTNAME}-${PORTVERSION}pre1
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= hendrik@scholz.net
+
+.if !defined(WITHOUT_LAME)
+BUILD_DEPENDS+= mp3rtp:${PORTSDIR}/audio/lame-devel
+CONFIGURE_ARGS+= --with-lame
+.endif
+.if defined(WITH_LIBDV)
+BUILD_DEPENDS+= encodedv:${PORTSDIR}/graphics/libdv
+CONFIGURE_ARGS+= --with-dv --with-dv-includes=${LOCALBASE} --with-dv-libs=${LOCALBASE}
+.endif
+.if defined(WITH_LIBA52)
+BUILD_DEPENDS+= a52dec:${PORTSDIR}/audio/liba52
+CONFIGURE_ARGS+= --with-a52
+.endif
+.if defined(WITH_NASM)
+BUILD_DEPENDS+= nasm:${PORTSDIR}/devel/nasm
+.endif
+.if !defined(WITHOUT_AVIFILE)
+BUILD_DEPENDS+= avifile-config:${PORTSDIR}/graphics/avifile
+CONFIGURE_ARGS+= --enable-avifile6
+.endif
+
+LIB_DEPENDS+= lthread.2:${PORTSDIR}/devel/linuxthreads:install
+
+USE_GLIB= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= LDFLAGS=-L${LOCALBASE}/lib CFLAGS="-I${X11BASE}/include -I${LOCALBASE}/include"
+
+pre-extract:
+.if defined(WITHOUT_LAME)
+ @${ECHO_MSG}
+ @${ECHO_MSG} "You disabled lame support !"
+.else
+ @${ECHO_MSG}
+ @${ECHO_MSG} "lame support is enabled. Disable with WITHOUT_LAME"
+ LAME= true
+.endif
+.if !defined(WITH_LIBDV)
+ @${ECHO_MSG}
+ @${ECHO_MSG} "You can enable libdv support by defining WITH_LIBDV"
+.else
+ @${ECHO_MSG}
+ @${ECHO_MSG} "You enabled libdv support by defining WITH_LIBDV"
+.endif
+.if !defined(WITH_LIBA52)
+ @${ECHO_MSG}
+ @${ECHO_MSG} "You can enable liba52 support by defining WITH_LIBDV"
+.else
+ @${ECHO_MSG}
+ @${ECHO_MSG} "You enabled liba52 support by defining WITH_LIBDV"
+.endif
+.if defined(WITHOUT_AVIFILE)
+ @${ECHO_MSG}
+ @${ECHO_MSG} "You disabled avifile support !"
+.else
+ @${ECHO_MSG}
+ @${ECHO_MSG} "avifile support is enabled. Disable with WITHOUT_AVIFILE"
+.endif(WITH_AVIFILE)
+
+.if !defined(WITH_NASM)
+ @${ECHO_MSG}
+ @${ECHO_MSG} "You can enable the nasm dependent moduley by defining WITH_NASM"
+.else
+ @${ECHO_MSG}
+ @${ECHO_MSG} "You enabled nsdm support by defining WITH_NASM"
+.endif(WITH_NASM)
+
+.include <bsd.port.mk>
diff --git a/graphics/transcode/distinfo b/graphics/transcode/distinfo
new file mode 100644
index 000000000000..a179eb5e3941
--- /dev/null
+++ b/graphics/transcode/distinfo
@@ -0,0 +1 @@
+MD5 (transcode-0.6.0pre1.tgz) = 1ba5e116e34be2e3132148e539d7fc54
diff --git a/graphics/transcode/files/patch-aa b/graphics/transcode/files/patch-aa
new file mode 100644
index 000000000000..7dd09b35b6ea
--- /dev/null
+++ b/graphics/transcode/files/patch-aa
@@ -0,0 +1,34 @@
+--- configure Thu Dec 13 20:17:56 2001
++++ configure Sun Dec 16 01:48:02 2001
+@@ -5177,11 +5177,11 @@
+ case "$target" in
+ *-*-freebsd*)
+ pthread_cflags="-D_REENTRANT -D_THREAD_SAFE"
+- pthread_lib="-pthread"
++ pthread_lib="-llthread"
+ ;;
+ *)
+ pthread_cflags="-D_REENTRANT"
+- pthread_lib="-lpthread"
++ pthread_lib="-llthread"
+ ;;
+ esac
+ LIBS="$pthread_lib $LIBS"
+@@ -5193,7 +5193,7 @@
+ #line 5193 "configure"
+ #include "confdefs.h"
+
+- #include <pthread.h>
++ #include <pthread/linuxthreads/pthread.h>
+
+ int
+ main ()
+@@ -10604,7 +10604,7 @@
+ qt_libs=""
+ fi;
+
+-EXTRA_LIBS="-lpng -lz -lpthread -lglib -ldl -lm"
++EXTRA_LIBS="-lpng -lz -llthread -lglib -ldl -lm"
+
+ if test x$with_qt = "x"yes ; then
+
diff --git a/graphics/transcode/files/patch-ab b/graphics/transcode/files/patch-ab
new file mode 100644
index 000000000000..d3e6f3ea9721
--- /dev/null
+++ b/graphics/transcode/files/patch-ab
@@ -0,0 +1,10 @@
+--- src/transcode.h Sun Dec 16 19:31:29 2001
++++ src/transcode.h Sun Dec 16 19:31:59 2001
+@@ -39,6 +39,7 @@
+ #include <string.h>
+
+ #ifdef NET_STREAM
++#include <sys/socket.h>
+ #include <netinet/in.h>
+ #include <netdb.h>
+ #endif
diff --git a/graphics/transcode/files/patch-ac b/graphics/transcode/files/patch-ac
new file mode 100644
index 000000000000..143bbf5afd7f
--- /dev/null
+++ b/graphics/transcode/files/patch-ac
@@ -0,0 +1,14 @@
+--- libmp3lame/rtp.c Sun Dec 16 19:42:01 2001
++++ libmp3lame/rtp.c Sun Dec 16 19:42:17 2001
+@@ -1,10 +1,10 @@
+ #include <stdlib.h>
+ #include <string.h>
++#include <sys/types.h>
+ #include <netinet/in.h>
+ #include <unistd.h>
+ #include <stdlib.h>
+ #include <stdio.h>
+-#include <sys/types.h>
+ #include <sys/socket.h>
+ #include <arpa/inet.h>
+
diff --git a/graphics/transcode/files/patch-ad b/graphics/transcode/files/patch-ad
new file mode 100644
index 000000000000..86b58cdcd602
--- /dev/null
+++ b/graphics/transcode/files/patch-ad
@@ -0,0 +1,44 @@
+--- export/divx4_vbr.c.orig Sun Dec 16 19:53:45 2001
++++ export/divx4_vbr.c Sun Dec 16 19:54:09 2001
+@@ -42,8 +42,6 @@
+ #include <dlfcn.h>
+ #include <math.h>
+
+-#include <stdint.h>
+-
+ #include "config.h"
+ #include "transcode.h"
+ #include "vbr.h"
+--- export/export_divx4.c.orig Sun Dec 16 19:53:25 2001
++++ export/export_divx4.c Sun Dec 16 19:53:35 2001
+@@ -35,8 +35,6 @@
+ #include <dlfcn.h>
+ #include <math.h>
+
+-#include <stdint.h>
+-
+ #include "divx4_encore2.h"
+ #include "transcode.h"
+ #include "avilib.h"
+--- export/export_xvid.c.orig Sun Dec 16 19:53:51 2001
++++ export/export_xvid.c Sun Dec 16 19:54:20 2001
+@@ -33,8 +33,6 @@
+ #include <dlfcn.h>
+ #include <math.h>
+
+-#include <stdint.h>
+-
+ #include "xvid_encore2.h"
+ #include "encore_ext.h"
+
+--- export/xvid_vbr.c.orig Sun Dec 16 19:53:57 2001
++++ export/xvid_vbr.c Sun Dec 16 19:54:30 2001
+@@ -42,8 +42,6 @@
+ #include <dlfcn.h>
+ #include <math.h>
+
+-#include <stdint.h>
+-
+ #include "config.h"
+ #include "transcode.h"
+ #include "vbr.h"
diff --git a/graphics/transcode/files/patch-ae b/graphics/transcode/files/patch-ae
new file mode 100644
index 000000000000..a3fd04c24dc9
--- /dev/null
+++ b/graphics/transcode/files/patch-ae
@@ -0,0 +1,10 @@
+--- export/export_net.c.orig Sun Dec 16 20:00:01 2001
++++ export/export_net.c Sun Dec 16 20:00:18 2001
+@@ -23,6 +23,7 @@
+
+ #include <stdio.h>
+ #include <stdlib.h>
++#include <sys/types.h>
+ #include <netinet/in.h>
+ #include <netdb.h>
+
diff --git a/graphics/transcode/files/patch-af b/graphics/transcode/files/patch-af
new file mode 100644
index 000000000000..26fca47dbef5
--- /dev/null
+++ b/graphics/transcode/files/patch-af
@@ -0,0 +1,19 @@
+--- import/nuv/rtjpeg_plugin.c.orig Fri Nov 30 19:52:41 2001
++++ import/nuv/rtjpeg_plugin.c Sun Dec 16 20:10:54 2001
+@@ -23,7 +23,6 @@
+
+ #define _LARGEFILE64_SOURCE 1
+
+-#include <features.h>
+ #include <stdio.h>
+ #include <stdlib.h>
+ #include <unistd.h>
+@@ -99,7 +98,7 @@
+ regions[0].end = -1;
+ }
+
+- rtjpeg_file=open(tplorg, O_RDONLY|O_LARGEFILE);
++ rtjpeg_file=open(tplorg, O_RDONLY);
+
+ if (rtjpeg_file == -1) {
+ fprintf(stderr, "File not found: %s\n", tplorg);
diff --git a/graphics/transcode/files/patch-ag b/graphics/transcode/files/patch-ag
new file mode 100644
index 000000000000..3f0ed431d26e
--- /dev/null
+++ b/graphics/transcode/files/patch-ag
@@ -0,0 +1,11 @@
+--- configure.org Tue Dec 18 18:12:10 2001
++++ configure Tue Dec 18 18:12:31 2001
+@@ -10747,7 +10747,7 @@
+ echo $ECHO_N "(cached) $ECHO_C" >&6
+ else
+ ac_check_lib_save_LIBS=$LIBS
+-LIBS="-ldv -L$with_dv_l -ldv ${EXTRA_LIBS} $LIBS"
++LIBS="-ldv -L$with_dv_l -ldv ${EXTRA_LIBS} $LIBS -llthread"
+ cat >conftest.$ac_ext <<_ACEOF
+ #line 10752 "configure"
+ #include "confdefs.h"
diff --git a/graphics/transcode/pkg-comment b/graphics/transcode/pkg-comment
new file mode 100644
index 000000000000..c8add8118114
--- /dev/null
+++ b/graphics/transcode/pkg-comment
@@ -0,0 +1 @@
+text-console based utility for video stream processing.
diff --git a/graphics/transcode/pkg-descr b/graphics/transcode/pkg-descr
new file mode 100644
index 000000000000..5f9d53d59c14
--- /dev/null
+++ b/graphics/transcode/pkg-descr
@@ -0,0 +1,13 @@
+transcode is a text-console utility for video stream processing.
+It supports elementary video and audio frame transformations, including
+de-interlacing or fast resizing of video frames and loading of external filters.
+
+A number of modules are included to enable import of DVDs on-the-fly,
+MPEG elementary (ES) or program streams (VOB), MPEG video, Digital Video (DV),
+YUV4MPEG streams, NuppelVideo file format and raw or compressed (pass-through)
+video frames and export modules for writing DivX;-), OpenDivX, DivX 4.xx or
+uncompressed AVI files with MPEG, AC3 (pass-through) or PCM audio.
+(Taken from the Website)
+
+WWW: http://www.theorie.physik.uni-goettingen.de/~ostreich/transcode/
+
diff --git a/graphics/transcode/pkg-plist b/graphics/transcode/pkg-plist
new file mode 100644
index 000000000000..638df75cebf9
--- /dev/null
+++ b/graphics/transcode/pkg-plist
@@ -0,0 +1,78 @@
+bin/transcode
+bin/tcmplex
+bin/tcextract
+bin/tcdecode
+bin/tcscan
+bin/tcdemux
+bin/tccat
+bin/tcprobe
+bin/avimerge
+bin/avisplit
+bin/avifix
+bin/avisync
+lib/transcode/export_null.so
+lib/transcode/export_null.la
+lib/transcode/export_wav.so
+lib/transcode/export_wav.la
+lib/transcode/export_opendivx.so
+lib/transcode/export_opendivx.la
+lib/transcode/export_raw.so
+lib/transcode/export_raw.la
+lib/transcode/export_divx4.so
+lib/transcode/export_divx4.la
+lib/transcode/export_ppm.so
+lib/transcode/export_ppm.la
+lib/transcode/export_yuv4mpeg.so
+lib/transcode/export_yuv4mpeg.la
+lib/transcode/export_xvid.so
+lib/transcode/export_xvid.la
+lib/transcode/export_net.so
+lib/transcode/export_net.la
+lib/transcode/export_mpeg.so
+lib/transcode/export_mpeg.la
+lib/transcode/export_af6.conf
+lib/transcode/import_nuv.so
+lib/transcode/import_nuv.la
+lib/transcode/import_net.so
+lib/transcode/import_net.la
+lib/transcode/import_avi.so
+lib/transcode/import_avi.la
+lib/transcode/import_mpeg2.so
+lib/transcode/import_mpeg2.la
+lib/transcode/import_ac3.so
+lib/transcode/import_ac3.la
+lib/transcode/import_vob.so
+lib/transcode/import_vob.la
+lib/transcode/import_raw.so
+lib/transcode/import_raw.la
+lib/transcode/import_yuv4mpeg.so
+lib/transcode/import_yuv4mpeg.la
+lib/transcode/import_null.so
+lib/transcode/import_null.la
+lib/transcode/import_dvd.so
+lib/transcode/import_dvd.la
+lib/transcode/filter_subtitler.so
+lib/transcode/filter_subtitler.la
+lib/transcode/filter_null.so
+lib/transcode/filter_null.la
+lib/transcode/filter_32detect.so
+lib/transcode/filter_32detect.la
+lib/transcode/filter_yuy2toyv12.so
+lib/transcode/filter_yuy2toyv12.la
+lib/transcode/filter_dilyuvmmx.so
+lib/transcode/filter_dilyuvmmx.la
+lib/transcode/filter_skip.so
+lib/transcode/filter_skip.la
+lib/transcode/filter_cut.so
+lib/transcode/filter_cut.la
+lib/transcode/filter_dnr.so
+lib/transcode/filter_dnr.la
+lib/transcode/filter_testframe.so
+lib/transcode/filter_testframe.la
+lib/transcode/import_mp3.la
+lib/transcode/import_mp3.so
+lib/transcode/a52_decore.la
+lib/transcode/a52_decore.so
+lib/transcode/import_dv.la
+lib/transcode/import_dv.so
+@dirrm lib/transcode