aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
Diffstat (limited to 'graphics')
-rw-r--r--graphics/imgv/Makefile1
-rw-r--r--graphics/inkscape/Makefile1
-rw-r--r--graphics/py-cairo/Makefile4
-rw-r--r--graphics/py-gdal/Makefile1
-rw-r--r--graphics/py3-cairo/Makefile4
5 files changed, 2 insertions, 9 deletions
diff --git a/graphics/imgv/Makefile b/graphics/imgv/Makefile
index d2bc2a60042a..f4ef715246c2 100644
--- a/graphics/imgv/Makefile
+++ b/graphics/imgv/Makefile
@@ -23,7 +23,6 @@ WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
USES= python:run shebangfix
SHEBANG_FILES= imgv.py
-python_OLD_CMD= /usr/bin/env python
post-patch:
@${REINPLACE_CMD} -e \
diff --git a/graphics/inkscape/Makefile b/graphics/inkscape/Makefile
index deb9629e2100..f31261251d3a 100644
--- a/graphics/inkscape/Makefile
+++ b/graphics/inkscape/Makefile
@@ -30,7 +30,6 @@ CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
CONFIGURE_ARGS= --without-gnome-vfs
-python_OLD_CMD?=/usr/bin/env python
python_CMD?= ${LOCALBASE}/bin/python2
SHEBANG_FILES= cxxtest/cxxtestgen.pl share/extensions/*.p[lm] \
share/extensions/*.py share/extensions/genpofiles.sh
diff --git a/graphics/py-cairo/Makefile b/graphics/py-cairo/Makefile
index 73f3c8e3fab6..ddcb501872e2 100644
--- a/graphics/py-cairo/Makefile
+++ b/graphics/py-cairo/Makefile
@@ -20,9 +20,7 @@ LDFLAGS+= -L${LOCALBASE}/lib
CONFIGURE_ENV= PYTHON=${LOCALBASE}/bin/${PYTHON_CMD} \
PREFIX=${PREFIX}
-python_OLD_CMD?= /usr/bin/env python
-python_CMD?= ${LOCALBASE}/bin/python2
-SHEBANG_FILES= examples/*.py examples/*/*.py test/*.py
+SHEBANG_FILES= examples/*.py examples/*/*.py test/*.py
post-install:
@cd ${STAGEDIR}${PREFIX} && ${PYTHON_CMD} ${PYTHON_LIBDIR}/compileall.py \
diff --git a/graphics/py-gdal/Makefile b/graphics/py-gdal/Makefile
index 64e768771d7a..8a1c55bcfe36 100644
--- a/graphics/py-gdal/Makefile
+++ b/graphics/py-gdal/Makefile
@@ -26,7 +26,6 @@ USES= python shebangfix tar:xz
WRKSRC= ${WRKDIR}/${DISTNAME}/swig/python
SHEBANG_FILES= scripts/*.py
-python_OLD_CMD= /usr/bin/env python
NUMPY_BUILD_DEPENDS= ${PKGNAMEPREFIX}numpy>=1.0.0:${PORTSDIR}/math/py-numpy
NUMPY_RUN_DEPENDS= ${PKGNAMEPREFIX}numpy>=1.0.0:${PORTSDIR}/math/py-numpy
diff --git a/graphics/py3-cairo/Makefile b/graphics/py3-cairo/Makefile
index 28c1e83c430b..34c4b3e61fdd 100644
--- a/graphics/py3-cairo/Makefile
+++ b/graphics/py3-cairo/Makefile
@@ -18,9 +18,7 @@ USE_GNOME= cairo
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-python_OLD_CMD?= /usr/bin/env python
-python_CMD?= ${LOCALBASE}/bin/python${PYTHON_VER}
-SHEBANG_FILES= examples/*.py examples/*/*.py test/*.py
+SHEBANG_FILES= examples/*.py examples/*/*.py test/*.py
PLIST_SUB+= PYTVER=${PYTHON_VER:S/.//}