aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
Diffstat (limited to 'graphics')
-rw-r--r--graphics/svgalib/Makefile2
-rw-r--r--graphics/svgalib/files/patch-utils-gtf-gtfcalc.c23
2 files changed, 24 insertions, 1 deletions
diff --git a/graphics/svgalib/Makefile b/graphics/svgalib/Makefile
index a5312b3148e2..5af91552d3b1 100644
--- a/graphics/svgalib/Makefile
+++ b/graphics/svgalib/Makefile
@@ -15,7 +15,7 @@ MAINTAINER= danfe@FreeBSD.org
COMMENT= A low level console graphics library
USE_GMAKE= yes
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
MANCOMPRESSED= yes
ALL_TARGET= shared static
diff --git a/graphics/svgalib/files/patch-utils-gtf-gtfcalc.c b/graphics/svgalib/files/patch-utils-gtf-gtfcalc.c
new file mode 100644
index 000000000000..199ebe268d94
--- /dev/null
+++ b/graphics/svgalib/files/patch-utils-gtf-gtfcalc.c
@@ -0,0 +1,23 @@
+--- utils/gtf/gtfcalc.c.orig Tue Jan 23 12:48:50 2007
++++ utils/gtf/gtfcalc.c Tue Jan 23 12:49:18 2007
+@@ -45,6 +45,7 @@
+ #include <string.h>
+ #include <ctype.h>
+ #include <math.h>
++#include <sys/param.h>
+ #include "gtf.h"
+
+ /*------------------------- Global Variables ------------------------------*/
+@@ -64,10 +65,12 @@
+
+ /*-------------------------- Implementation -------------------------------*/
+
++#if __FreeBSD_version < 503000
+ static double round(double v)
+ {
+ return floor(v + 0.5);
+ }
++#endif
+
+ static void GetInternalConstants(GTF_constants *c)
+ /****************************************************************************