aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
Diffstat (limited to 'graphics')
-rw-r--r--graphics/py-pyglet/Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/graphics/py-pyglet/Makefile b/graphics/py-pyglet/Makefile
index f1635fa831aa..845d25a27be2 100644
--- a/graphics/py-pyglet/Makefile
+++ b/graphics/py-pyglet/Makefile
@@ -3,7 +3,7 @@
PORTNAME= pyglet
PORTVERSION= 1.1.4
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= graphics multimedia x11-toolkits python
MASTER_SITES= GOOGLE_CODE
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -14,7 +14,8 @@ COMMENT= Cross-platform windowing and multimedia library for Python
LICENSE= BSD
LIB_DEPENDS= libfreetype.so:${PORTSDIR}/print/freetype2 \
- libfontconfig.so:${PORTSDIR}/x11-fonts/fontconfig
+ libfontconfig.so:${PORTSDIR}/x11-fonts/fontconfig \
+RUN_DEPENDS= ${LOCALBASE}/lib/libavbin.so:${PORTSDIR}/multimedia/avbin
USE_PYTHON= yes
USE_PYDISTUTILS=yes
@@ -33,6 +34,8 @@ IGNORE= crashes or doesn't work on !i386
.endif
post-install:
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ cd ${WRKSRC} && ${INSTALL_DATA} CHANGELOG NOTICE README ${STAGEDIR}${DOCSDIR}/
cd ${WRKSRC}/doc && ${COPYTREE_SHARE} . ${STAGEDIR}${DOCSDIR}/
cd ${WRKSRC}/examples && ${COPYTREE_SHARE} . ${STAGEDIR}${EXAMPLESDIR}/