aboutsummaryrefslogtreecommitdiffstats
path: root/irc/ircproxy/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'irc/ircproxy/Makefile')
-rw-r--r--irc/ircproxy/Makefile13
1 files changed, 12 insertions, 1 deletions
diff --git a/irc/ircproxy/Makefile b/irc/ircproxy/Makefile
index 22a03c861cc9..83a3c288cd76 100644
--- a/irc/ircproxy/Makefile
+++ b/irc/ircproxy/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= ircproxy
-PORTVERSION= 1.3.4c
+PORTVERSION= 1.3.6
CATEGORIES= irc
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
@@ -15,10 +15,17 @@ COMMENT= An IRC proxy/bouncer daemon
LIB_DEPENDS= cares.2:${PORTSDIR}/dns/c-ares
+USE_BZIP2= yes
GNU_CONFIGURE= yes
LDFLAGS+= -L${LOCALBASE}/lib
CFLAGS+= -I${LOCALBASE}/include
+USERS= ircproxyd
+GROUPS= ircproxyd
+
+SUB_LIST= IRC_USR=${USERS} IRC_GRP=${GROUPS}
+SUB_FILES= pkg-deinstall
+
OPTIONS= SSL "Enable SSL support" on \
IPV6 "Enable IPv6 support" on \
MEMDEBUG "Enable memory debugging" on \
@@ -48,4 +55,8 @@ CONFIGURE_ARGS+= --enable-fddebug
CONFIGURE_ARGS+= --disable-fddebug
.endif
+post-patch:
+ @${REINPLACE_CMD} -e 's|EUSER="ircproxy"|EUSER="ircproxyd"|g; \
+ s|EGROUP="users"|EGROUP="ircproxyd"|g' ${WRKSRC}/data/${PORTNAME}d.conf
+
.include <bsd.port.post.mk>