aboutsummaryrefslogtreecommitdiffstats
path: root/irc/xchat-systray-plugin/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'irc/xchat-systray-plugin/Makefile')
-rw-r--r--irc/xchat-systray-plugin/Makefile12
1 files changed, 7 insertions, 5 deletions
diff --git a/irc/xchat-systray-plugin/Makefile b/irc/xchat-systray-plugin/Makefile
index 1c7291594417..783db7c8a6cf 100644
--- a/irc/xchat-systray-plugin/Makefile
+++ b/irc/xchat-systray-plugin/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= xchat-systray-plugin
-PORTVERSION= 2.4.0
-PORTREVISION= 2
+PORTVERSION= 2.4.5
CATEGORIES= irc
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= xchat2-plugins
@@ -18,7 +17,6 @@ COMMENT= Systray icon plugin for X-Chat
RUN_DEPENDS= xchat:${PORTSDIR}/irc/xchat2
-PLIST_FILES= lib/xchat/plugins/systray.so
WRKSRC= ${WRKDIR}/xchat-systray-integration-${PORTVERSION}
USE_X_PREFIX= yes
USE_GMAKE= yes
@@ -26,9 +24,13 @@ USE_GNOME= gtk20
USE_REINPLACE= yes
post-patch:
- @${REINPLACE_CMD} -e 's|-O2|${CFLAGS} -fPIC|' ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e 's|-Os|${CFLAGS} -fPIC|' ${WRKSRC}/Makefile
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/systray.so ${X11BASE}/lib/xchat/plugins/
+ ${INSTALL_PROGRAM} ${WRKSRC}/systray.so ${PREFIX}/lib/xchat/plugins/
+ ${MKDIR} ${PREFIX}/lib/xchat/plugins/GTKTray
+ ${INSTALL_DATA} ${WRKSRC}/src/images/GTKTray/* ${PREFIX}/lib/xchat/plugins/GTKTray
+ ${MKDIR} ${PREFIX}/lib/xchat/plugins/Menu
+ ${INSTALL_DATA} ${WRKSRC}/src/images/Menu/* ${PREFIX}/lib/xchat/plugins/Menu
.include <bsd.port.mk>