aboutsummaryrefslogtreecommitdiffstats
path: root/irc/znc/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'irc/znc/Makefile')
-rw-r--r--irc/znc/Makefile58
1 files changed, 20 insertions, 38 deletions
diff --git a/irc/znc/Makefile b/irc/znc/Makefile
index ce9861173659..22f78b36f2cb 100644
--- a/irc/znc/Makefile
+++ b/irc/znc/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= znc
-PORTVERSION= 1.6.1
-PORTREVISION= 1
+PORTVERSION= 1.6.2
CATEGORIES= irc ipv6
MASTER_SITES= http://znc.in/releases/ \
http://znc.in/releases/archive/
@@ -18,58 +17,42 @@ GNU_CONFIGURE= yes
USE_RC_SUBR= znc
USES= compiler:c++11-lib cpe gmake iconv pkgconfig
-NO_OPTIONS_SORT= yes
-
-OPTIONS_DEFINE= DEBUG IPV6 OPENSSL CYRUS PERL PYTHON TCL CHARSET DOCS
+OPTIONS_DEFINE= CHARSET CYRUS DEBUG DOCS IPV6 OPENSSL PERL PYTHON TCL
OPTIONS_DEFAULT= OPENSSL PERL
OPTIONS_SUB= yes
+CHARSET_DESC= Character encoding support via ICU
CYRUS_DESC= Cyrus SASL module
DEBUG_DESC= Debugging support
PERL_DESC= Perl scripting module
PYTHON_DESC= Python scripting module
-CHARSET_DESC= Character encoding support via ICU
TCL_DESC= Tcl scripting module
+CHARSET_CONFIGURE_OFF= --disable-charset
+CHARSET_LIB_DEPENDS= libicuuc.so.55:${PORTSDIR}/devel/icu \
+ libicudata.so.55:${PORTSDIR}/devel/icu
CYRUS_CONFIGURE_ON= --enable-cyrus
CYRUS_LDFLAGS= -L${LOCALBASE}/lib
CYRUS_LIB_DEPENDS= libsasl2.so:${PORTSDIR}/security/cyrus-sasl2
DEBUG_CONFIGURE_ON= --enable-debug
IPV6_CONFIGURE_OFF= --disable-ipv6
+OPENSSL_CONFIGURE_OFF= --disable-openssl
+OPENSSL_CONFIGURE_ON= --with-openssl=${OPENSSLBASE}
+OPENSSL_USE= openssl=yes
PERL_BUILD_DEPENDS= swig30>=3.0.0:${PORTSDIR}/devel/swig30
PERL_CONFIGURE_ENABLE= perl
PERL_CONFIGURE_ON= --enable-swig
+PERL_USE= perl5=build,run
PERL_USES= perl5
PYTHON_BUILD_DEPENDS= swig30>=3.0.0:${PORTSDIR}/devel/swig30
PYTHON_CONFIGURE_ON= --enable-python=python-${PYTHON_VER} --enable-swig
+PYTHON_USE= perl5=build
PYTHON_USES= perl5 python:3
-OPENSSL_CONFIGURE_OFF= --disable-openssl
-CHARSET_CONFIGURE_OFF= --disable-charset
-CHARSET_LIB_DEPENDS= libicuuc.so.55:${PORTSDIR}/devel/icu \
- libicudata.so.55:${PORTSDIR}/devel/icu
TCL_CONFIGURE_ENABLE= tcl
+TCL_CONFIGURE_ON= --with-tcl=${TCL_LIBDIR}
+TCL_USES= tcl
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MOPENSSL}
-.include "${PORTSDIR}/Mk/bsd.openssl.mk"
-CONFIGURE_ARGS+= --with-openssl=${OPENSSLBASE}
-.endif
-
-.if ${PORT_OPTIONS:MPERL}
-USE_PERL5+= run build
-.endif
-
-.if ${PORT_OPTIONS:MTCL}
-USES+= tcl
-CONFIGURE_ARGS+= --with-tcl=${TCL_LIBDIR}
-.endif
-
-.if ${PORT_OPTIONS:MPYTHON}
-USE_PERL5+= build
-.endif
-
-PORTDOCS= README.md
+PORTDOCS= README.md
pre-configure:
# No need to cast to char** in AM_ICONV, fixes charset/iconv detection
@@ -77,14 +60,15 @@ pre-configure:
@${REINPLACE_CMD} -e \
's#(char \*\*)##g' \
${WRKSRC}/configure
+
# Instead of using bundled swig generated files, delete them to force
# regeneration using swig 2.0.11+ (fixes port compilation using clang)
-.if ${PORT_OPTIONS:MPERL}
+#
+pre-configure-PERL-on:
@${RM} ${WRKSRC}/modules/modperl/ZNC.cpp
-.endif
-.if ${PORT_OPTIONS:MPYTHON}
+
+pre-configure-PYTHON-on:
@${RM} ${WRKSRC}/modules/modpython/_znc_core.cpp
-.endif
post-patch:
@${REINPLACE_CMD} -e \
@@ -93,13 +77,11 @@ post-patch:
@${REINPLACE_CMD} -e \
's#/usr/local#${LOCALBASE}#' ${WRKSRC}/configure
-post-install:
-.if ${PORT_OPTIONS:MDOCS}
+post-install-DOCS-on:
${MKDIR} ${STAGEDIR}${DOCSDIR}
.for f in ${PORTDOCS}
${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${DOCSDIR}
.endfor
@${ECHO_MSG} "===> Documentation installed in ${DOCSDIR}"
-.endif
.include <bsd.port.mk>