aboutsummaryrefslogtreecommitdiffstats
path: root/japanese/eblook/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'japanese/eblook/Makefile')
-rw-r--r--japanese/eblook/Makefile34
1 files changed, 34 insertions, 0 deletions
diff --git a/japanese/eblook/Makefile b/japanese/eblook/Makefile
new file mode 100644
index 000000000000..828b92e57a20
--- /dev/null
+++ b/japanese/eblook/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: eblook
+# Version required: 1.2
+# Date created: 20 August 1999
+# Whom: Shigeyuki Fukushima <shige@FreeBSD.org>
+#
+# $Id$
+#
+
+DISTNAME= eblook-1.2
+PKGNAME= ja-eblook-1.2
+CATEGORIES= japanese textproc
+MASTER_SITES= http://openlab.ring.gr.jp/lookup/DIST/eblook/
+
+MAINTAINER= shige@FreeBSD.org
+
+DOCDIR= share/doc/eblook
+
+LIB_DEPENDS= eb.3:${PORTSDIR}/japanese/eb
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-eb-includes=${PREFIX}/include \
+ --with-eb-libraries=${PREFIX}/lib
+
+PLIST_SUB= DOCDIR=${DOCDIR}
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @[ ! -d ${PREFIX}/${DOCDIR} ] && ${MKDIR} ${PREFIX}/${DOCDIR}
+ @for i in AUTHORS COPYING ChangeLog NEWS README ; do \
+ ${INSTALL_DATA} ${WRKSRC}/$${i} ${PREFIX}/${DOCDIR} ;\
+ done
+.endif
+
+.include <bsd.port.mk>