aboutsummaryrefslogtreecommitdiffstats
path: root/japanese/gedy/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'japanese/gedy/Makefile')
-rw-r--r--japanese/gedy/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/japanese/gedy/Makefile b/japanese/gedy/Makefile
new file mode 100644
index 000000000000..fc268951cb20
--- /dev/null
+++ b/japanese/gedy/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: gedy
+# Date created: 21 February 2010
+# Whom: Hajimu UMEMOTO <ume@FreeBSD.org>
+#
+# $FreeBSD$
+
+PORTNAME= gedy
+PORTVERSION= 0.02
+#PORTREVISION= 0
+CATEGORIES= japanese ruby
+MASTER_SITES= http://homepage3.nifty.com/slokar/pasori/
+DISTNAME= ${PORTNAME}
+EXTRACT_SUFX= # empty
+
+MAINTAINER= ume@FreeBSD.org
+COMMENT= GNOME Edy Viewer
+
+RUN_DEPENDS= ${RUBY_SITEARCHLIBDIR}/gnome2.so:${PORTSDIR}/x11/ruby-gnome2 \
+ ${RUBY_SITEARCHLIBDIR}/gconf2.so:${PORTSDIR}/devel/ruby-gconf2 \
+ ${RUBY_SITEARCHLIBDIR}/pasori.so:${PORTSDIR}/devel/libpafe-ruby
+
+USE_RUBY= yes
+
+EXTRACT_CMD= ${CP}
+EXTRACT_BEFORE_ARGS= -p
+EXTRACT_AFTER_ARGS= .
+NO_WRKSUBDIR= yes
+NO_BUILD= yes
+
+PLIST_FILES= bin/${PORTNAME}
+
+do-install:
+ @${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+
+.include <bsd.port.mk>