aboutsummaryrefslogtreecommitdiffstats
path: root/japanese/migemo/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'japanese/migemo/Makefile')
-rw-r--r--japanese/migemo/Makefile22
1 files changed, 18 insertions, 4 deletions
diff --git a/japanese/migemo/Makefile b/japanese/migemo/Makefile
index cbf2b4fccc32..eb364ace05e6 100644
--- a/japanese/migemo/Makefile
+++ b/japanese/migemo/Makefile
@@ -7,20 +7,34 @@
PORTNAME= migemo
PORTVERSION= 0.21
+PORTREVISION= 1
CATEGORIES= japanese elisp
MASTER_SITES= http://migemo.namazu.org/stable/
PKGNAMESUFFIX= -${EMACS_PORT_NAME}
MAINTAINER= nobutaka@nobutaka.com
-BUILD_DEPENDS= ${LOCALBASE}/${EMACS_LIBDIR_WITH_VER}/site-lisp/emu/emu.el:${PORTSDIR}/editors/apel-${EMACS_PORT_NAME} \
- ${NONEXISTENT}:${SKK_PORT_DIR}:extract
+EMACS_PORT_NAME?= emacs20
+
+.if (${EMACS_PORT_NAME} == "xemacs21-mule")
+EMACS_PACKAGESDIR= lib/xemacs/site-packages
+
+BUILD_DEPENDS= ${LOCALBASE}/${EMACS_PACKAGESDIR}/lisp/apel/emu.el:${PORTSDIR}/editors/apel-${EMACS_PORT_NAME}
+RUN_DEPENDS= ${LOCALBASE}/${EMACS_PACKAGESDIR}/lisp/apel/emu.el:${PORTSDIR}/editors/apel-${EMACS_PORT_NAME}
+.else
+BUILD_DEPENDS= ${LOCALBASE}/${EMACS_LIBDIR_WITH_VER}/site-lisp/emu/emu.el:${PORTSDIR}/editors/apel-${EMACS_PORT_NAME}
RUN_DEPENDS= ${LOCALBASE}/${EMACS_LIBDIR_WITH_VER}/site-lisp/emu/emu.el:${PORTSDIR}/editors/apel-${EMACS_PORT_NAME}
+.endif
+BUILD_DEPENDS+= ${NONEXISTENT}:${SKK_PORT_DIR}:extract
USE_PERL5= yes
-USE_AUTOCONF= yes
+USE_AUTOMAKE= yes
+
+CONFIGURE_ARGS= --with-emacs=${EMACS_CMD}
+.if (${EMACS_PORT_NAME} == "xemacs21-mule")
+CONFIGURE_ARGS+= --with-lispdir=${PREFIX}/${EMACS_LIBDIR}/site-lisp
+.endif
-EMACS_PORT_NAME=emacs20
SKK_PORT_DIR= ${PORTSDIR}/japanese/skk-jisyo
.include <bsd.port.pre.mk>