aboutsummaryrefslogtreecommitdiffstats
path: root/java/cacao/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'java/cacao/Makefile')
-rw-r--r--java/cacao/Makefile8
1 files changed, 8 insertions, 0 deletions
diff --git a/java/cacao/Makefile b/java/cacao/Makefile
index be3393493623..1a9be57a0f96 100644
--- a/java/cacao/Makefile
+++ b/java/cacao/Makefile
@@ -6,6 +6,7 @@
PORTNAME= cacao
PORTVERSION= 0.97
+PORTREVISION= 1
CATEGORIES= java devel
MASTER_SITES= http://www.complang.tuwien.ac.at/cacaojvm/download/cacao-${PORTVERSION}/
@@ -18,6 +19,7 @@ USE_AUTOTOOLS= libltdl
USE_JAVA= yes
JAVA_VERSION= 1.4+
GNU_CONFIGURE= yes
+MAN1= cacao.1
CONFIGURE_ARGS+= --with-classpath-prefix=${LOCALBASE}
CONFIGURE_ENV= CFLAGS="${CFLAGS} -I${LOCALBASE}/include" \
LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib"
@@ -28,4 +30,10 @@ CONFIGURE_ENV= CFLAGS="${CFLAGS} -I${LOCALBASE}/include" \
IGNORE= unsupported architecture
.endif
+post-patch:
+ ${REINPLACE_CMD} -e "s, man,," ${WRKSRC}/Makefile.in
+
+post-install:
+ ${INSTALL_MAN} ${WRKSRC}/man/cacao.1 ${MANPREFIX}/man/man1
+
.include <bsd.port.post.mk>