aboutsummaryrefslogtreecommitdiffstats
path: root/java/eclipse-pydev/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'java/eclipse-pydev/Makefile')
-rw-r--r--java/eclipse-pydev/Makefile28
1 files changed, 20 insertions, 8 deletions
diff --git a/java/eclipse-pydev/Makefile b/java/eclipse-pydev/Makefile
index 401e77a67cd0..a01be32821c5 100644
--- a/java/eclipse-pydev/Makefile
+++ b/java/eclipse-pydev/Makefile
@@ -7,7 +7,7 @@
PORTNAME= pydev
PORTVERSION= 2.6.0
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= java devel python
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/PyDev%20${PORTVERSION}/
PKGNAMEPREFIX= eclipse-
@@ -31,28 +31,40 @@ JYTHON_DESC= Use Jython as Python interpreter
RUN_DEPENDS+= jython:${PORTSDIR}/lang/jython
.endif
-PLIST_SUB= PORTVERSION=${PORTVERSION}.${DISTDATE}
-
USE_PYTHON= yes
USE_ZIP= yes
DISTDATE= 2012062818
+SUB_FILES= pkg-install
+SUB_LIST= BUNDLES_INFO=${BUNDLES_INFO} DISTDATE=${DISTDATE} \
+ PLUGINDIR=${PLUGINDIR} PORTVERSION=${PORTVERSION}
+
pre-install:
@# ignore javashell.py file, because there is a syntax error
@# see http://goo.gl/E4epH
${PYTHON_CMD} -m compileall -x javashell.py -f ${WRKSRC}/plugins
${PYTHON_CMD} -O -m compileall -x javashell.py -f ${WRKSRC}
+REVDOM= python.pydev
+PLUGINDIR= ../../share/eclipse/dropins/pydev/eclipse/plugins
+BUNDLES_INFO= ${PREFIX}/lib/eclipse/configuration/org.eclipse.equinox.simpleconfigurator/bundles.info
+COMPONENTS= com com.analysis com.codecompletion com.debug com.fastparser com.refactoring \
+ org org.ast org.core org.customizations org.debug org.django org.help org.jython org.parser org.red_core org.refactoring
post-install:
- @# Update the bundles.info...
- @${LOCALBASE}/bin/eclipse -consoleLog -initialize
- @${CAT} ${PKGMESSAGE}
+ @${ECHO_MSG} "===> Updating ${BUNDLES_INFO}"
+.for d in com org
+. for c in ${COMPONENTS:M${d}*}
+ @${ECHO_CMD} "${d}.${REVDOM}${c:S,${d},,},${PORTVERSION}.${DISTDATE},${PLUGINDIR}/${d}.${REVDOM}${c:S,${d},,}_${PORTVERSION}.${DISTDATE}/,4,false" >> ${BUNDLES_INFO}
+. endfor
+.endfor
+ @(${SORT} ${BUNDLES_INFO} > ${BUNDLES_INFO}.sort) && \
+ ${MV} ${BUNDLES_INFO}.sort ${BUNDLES_INFO}
+ ${CAT} ${PKGMESSAGE}
add-plist-post:
@${ECHO_CMD} "@exec ${MKDIR} %D/share/eclipse/dropins/${PORTNAME}/eclipse/plugins/com.python.pydev.codecompletion_${PORTVERSION}.${DISTDATE}/icons" >> ${TMPPLIST}
- @${ECHO_CMD} "@exec ${LOCALBASE}/bin/eclipse -consoleLog -initialize" >> ${TMPPLIST}
- @${ECHO_CMD} "@unexec ${LOCALBASE}/bin/eclipse -consoleLog -initialize" >> ${TMPPLIST}
+ @${ECHO_CMD} "@unexec ${SED} -i '' -E '/^((org)|(com))\.python\.pydev/d' %D/lib/eclipse/configuration/org.eclipse.equinox.simpleconfigurator/bundles.info" >> ${TMPPLIST}
.include "${PORTSDIR}/java/eclipse/Makefile.plugins"