aboutsummaryrefslogtreecommitdiffstats
path: root/java/wildfly82/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'java/wildfly82/Makefile')
-rw-r--r--java/wildfly82/Makefile28
1 files changed, 27 insertions, 1 deletions
diff --git a/java/wildfly82/Makefile b/java/wildfly82/Makefile
index eeeb903d751f..ec73e69083b2 100644
--- a/java/wildfly82/Makefile
+++ b/java/wildfly82/Makefile
@@ -3,7 +3,7 @@
PORTNAME= wildfly82
PORTVERSION= 8.2.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= java www
MASTER_SITES= http://download.jboss.org/wildfly/${WILDFLY_VERSION}/
DISTNAME= wildfly-${WILDFLY_VERSION}
@@ -32,6 +32,28 @@ SUB_LIST= APP_SHORTNAME=${PORTNAME} \
APP_HOME=${PREFIX}/wildfly-${PORTVERSION}
PLIST_SUB= APP_HOME=wildfly-${PORTVERSION}
+CONFIG_FILES= appclient/configuration/appclient.xml \
+ appclient/configuration/logging.properties \
+ domain/configuration/application-roles.properties \
+ domain/configuration/application-users.properties \
+ domain/configuration/default-server-logging.properties \
+ domain/configuration/domain.xml \
+ domain/configuration/host-master.xml \
+ domain/configuration/host-slave.xml \
+ domain/configuration/host.xml \
+ domain/configuration/logging.properties \
+ domain/configuration/mgmt-groups.properties \
+ domain/configuration/mgmt-users.properties \
+ standalone/configuration/application-roles.properties \
+ standalone/configuration/application-users.properties \
+ standalone/configuration/logging.properties \
+ standalone/configuration/mgmt-groups.properties \
+ standalone/configuration/mgmt-users.properties \
+ standalone/configuration/standalone-full-ha.xml \
+ standalone/configuration/standalone-full.xml \
+ standalone/configuration/standalone-ha.xml \
+ standalone/configuration/standalone.xml
+
post-patch:
${RM} ${WRKSRC}/bin/add-user.sh.orig
@@ -45,5 +67,9 @@ do-install:
(cd ${WRKSRC} && ${COPYTREE_SHARE} . ${STAGEDIR}${PREFIX}/wildfly-${PORTVERSION})
${CHMOD} +x ${STAGEDIR}${PREFIX}/wildfly-${PORTVERSION}/bin/*.sh
${RMDIR} ${STAGEDIR}${PREFIX}/wildfly-${PORTVERSION}/.installation
+.for FILE in ${CONFIG_FILES}
+ ${MV} ${STAGEDIR}${PREFIX}/wildfly-${PORTVERSION}/${FILE} \
+ ${STAGEDIR}${PREFIX}/wildfly-${PORTVERSION}/${FILE}.sample
+.endfor
.include <bsd.port.mk>