aboutsummaryrefslogtreecommitdiffstats
path: root/korean/byeoroo
diff options
context:
space:
mode:
Diffstat (limited to 'korean/byeoroo')
-rw-r--r--korean/byeoroo/Makefile34
-rw-r--r--korean/byeoroo/distinfo1
-rw-r--r--korean/byeoroo/pkg-comment1
-rw-r--r--korean/byeoroo/pkg-descr13
-rw-r--r--korean/byeoroo/pkg-plist18
5 files changed, 67 insertions, 0 deletions
diff --git a/korean/byeoroo/Makefile b/korean/byeoroo/Makefile
new file mode 100644
index 000000000000..c58bf4e5883a
--- /dev/null
+++ b/korean/byeoroo/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: byeoroo
+# Version required: byeoroo-0.0.19990503
+# Date created: 04 Jun 1999
+# Whom: CHOI Junho <cjh@kr.freebsd.org>
+#
+# $Id$
+#
+
+DISTNAME= byeoroo-0.0.19990605.3
+PKGNAME= ko-byeoroo-0.0.19990605.3
+CATEGORIES= korean x11
+MASTER_SITES= http://adam.kaist.ac.kr/~cwryu/archive/byeoroo/
+
+MAINTAINER= cjh@kr.freebsd.org
+
+RUN_DEPENDS= ${PREFIX}/lib/X11/fonts/local/johabm16.pcf.gz:${PORTSDIR}/korean/johabfonts \
+ ${X11BASE}/lib/X11/fonts/local/hgm12.pcf.gz:${PORTSDIR}/korean/hanyangfonts
+
+USE_X_PREFIX= yes
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+
+post-install:
+ # patch XLC_LOCALE for ko_KR.EUC(harmless)
+ if [ -f ${PREFIX}/lib/X11/locale/ko/XLC_LOCALE ]; then \
+ ${MV} -f ${PREFIX}/lib/X11/locale/ko/XLC_LOCALE \
+ ${PREFIX}/lib/X11/locale/ko/XLC_LOCALE.orig; \
+ fi
+ ${INSTALL_DATA} ${FILESDIR}/XLC_LOCALE \
+ ${PREFIX}/lib/X11/locale/ko/
+ ${INSTALL_DATA} ${FILESDIR}/XLC_LOCALE \
+ ${PREFIX}/share/byeoroo/
+
+.include <bsd.port.mk>
diff --git a/korean/byeoroo/distinfo b/korean/byeoroo/distinfo
new file mode 100644
index 000000000000..2832cbbb51ab
--- /dev/null
+++ b/korean/byeoroo/distinfo
@@ -0,0 +1 @@
+MD5 (byeoroo-0.0.19990605.3.tar.gz) = 258bf951bd01e628997ebd372fd0b5db
diff --git a/korean/byeoroo/pkg-comment b/korean/byeoroo/pkg-comment
new file mode 100644
index 000000000000..b24aadaa9793
--- /dev/null
+++ b/korean/byeoroo/pkg-comment
@@ -0,0 +1 @@
+Korean X11 Input Method
diff --git a/korean/byeoroo/pkg-descr b/korean/byeoroo/pkg-descr
new file mode 100644
index 000000000000..2c9283f3b43e
--- /dev/null
+++ b/korean/byeoroo/pkg-descr
@@ -0,0 +1,13 @@
+Byeoroo: An X11R6 Input Method Server for the Korean Language
+
+ Byeoroo supports over-the-spot, off-the-spot input styles.
+ For more information, please refer documentation files.
+
+ *NOTE*: Byeoroo is in an alpha stage and very unstable.
+ Use at your own risk.
+
+ Byeoroo is by Park, Jae-hyon <jhpark@entropy.kaist.ac.kr>
+ Autoconf patch by Changwoo Ryu <cwryu@adam.kaist.ac.kr>
+
+--
+CHOI Junho <cjh@kr.freebsd.org>
diff --git a/korean/byeoroo/pkg-plist b/korean/byeoroo/pkg-plist
new file mode 100644
index 000000000000..1c02503b0e39
--- /dev/null
+++ b/korean/byeoroo/pkg-plist
@@ -0,0 +1,18 @@
+bin/byeoroo
+lib/byeoroo/byeoroo.real
+@dirrm lib/byeoroo
+share/byeoroo/2.kdf
+share/byeoroo/Byeoroo
+share/byeoroo/loose390.kdf
+share/byeoroo/strict390.kdf
+share/byeoroo/strict3f.kdf
+share/byeoroo/qwertywhole.ksm
+share/byeoroo/raw.ksm
+share/byeoroo/sample.cd
+share/byeoroo/sample.cdi
+share/byeoroo/XLC_LOCALE
+@comment copy new locale definition(no harm, so need not be uninstalled)
+@exec if [ -f %D/lib/X11/locale/ko/XLC_LOCALE ]; then mv -f %D/lib/X11/locale/ko/XLC_LOCALE %D/lib/X11/locale/ko/XLC_LOCALE.orig; fi
+@exec cp %D/share/byeoroo/XLC_LOCALE %D/lib/X11/locale/ko/
+@unexec if [ -f %D/lib/X11/locale/ko/XLC_LOCALE.orig ]; then mv -f %D/lib/X11/locale/ko/XLC_LOCALE.orig %D/lib/X11/locale/ko/XLC_LOCALE; fi
+@dirrm share/byeoroo
/td>2-0/+6 * Properly handle correct and incorrect (for the common case, ie Outlook andJeffrey Stedfast2001-06-151-0/+17 * Don't try to format the Reply-To header - we don't want to wrap theJeffrey Stedfast2001-06-152-0/+6 * A new provider, for spool mailboxes. Mostly a cut and paste of the mboxNot Zed2001-06-1222-51/+2468 * Add a separator between the service url and the folder name, if needed.Jon Trowbridge2001-06-082-1/+16 * Added an argument, so that the original source URI of the mbox can beJon Trowbridge2001-06-083-9/+27 * Don't fetch the UID and FLAGS of messages we don't know about yet, sinceDan Winship2001-06-062-30/+40 * Fix to not get into a recursive loop in get_type().Jeffrey Stedfast2001-06-034-41/+49 * Numerous fixes to get it to compile.Jeffrey Stedfast2001-06-014-62/+383 * Added camel-cipher-context.h, camel-cms-context.h, camel-smime-context.h,Jeffrey Stedfast2001-06-012-0/+7 * New virtual class for manipulating cryptographic message syntax messagesJeffrey Stedfast2001-06-019-939/+1291 * Redo the BUILD_MAP code to not depend on libunicode. Now it only generatesDan Winship2001-05-314-4091/+274 * Fix an obvious typoDan Winship2001-05-301-1/+1 * Remove this evolutionary dead endDan Winship2001-05-3010-1689/+0 * Create a CamelDiscoDiary. (imap_disconnect_offline): And free it.Dan Winship2001-05-307-72/+507 * Code for logging and replaying offline operations.Dan Winship2001-05-3010-75/+706 * Use g_strcasecmp() because some systems don't have strcasecmp(). Also,Jeffrey Stedfast2001-05-293-3/+10 * changelog entries for tests/ fixes committed yesterdayDan Winship2001-05-291-0/+20 * Fix an fd leakDan Winship2001-05-2819-646/+118 * Add a "need_rescan" flag saying if we want to rescan the entire folder forDan Winship2001-05-274-24/+66 * Oops. Use a strNcmp to make sure the response begins with a 334 code, notJeffrey Stedfast2001-05-262-1/+5 * remove the summary info so we are not out-of-sync with the maildir folder.Jeffrey Stedfast2001-05-264-71/+100 * Oops, I spelled the get-default-db function name wrong.Jeffrey Stedfast2001-05-252-1/+7 * s/folder_deleted/folder_created - result of a bad copy/paste.Jeffrey Stedfast2001-05-242-1/+5 * Optimize the match "" case.Jeffrey Stedfast2001-05-242-17/+35 * Store the CamelFolderInfo tree that was returned fromJeffrey Stedfast2001-05-223-5/+17 * The service can be NULL here too, thanks to Wayne Davis for pointing thisJeffrey Stedfast2001-05-172-1/+3 * We don't need to be passed the certdb path anymore.Jeffrey Stedfast2001-05-173-4/+8 * New function to return an array of all headers.Dan Winship2001-05-174-2/+108 * Don't close or free (it wasn't allocated) the certdb.Jeffrey Stedfast2001-05-162-13/+11 * Don't use EXTRA_GNOME_*, use the new CAMEL_* variables so we don't link inJeffrey Stedfast2001-05-163-4/+7 * Added t the test suite - tests the S/MIME pkcs7 functions.Jeffrey Stedfast2001-05-163-2/+186 * Lots of fixes to get this to compile.Jeffrey Stedfast2001-05-152-4/+2 * bah, just mod the pgp-context macro for camel_pgp_verify so that we don't hav...Jeffrey Stedfast2001-05-152-2/+2 * Lots of fixes to get this to almost compile. Still struggling with theJeffrey Stedfast2001-05-159-39/+95 * Add camel-smime-context.[c,h] and camel-smime.[c,h] to the build.Jeffrey Stedfast2001-05-156-14/+568 * Replicate the semantics of the libunicode utf8 functions by returning NULLJon Trowbridge2001-05-155-8/+30 * Subclass CamelSession since we can no longer specify the passwd callbackJeffrey Stedfast2001-05-1512-89/+727 * er, OptionSetJeffrey Stedfast2001-05-131-1/+1 * s/SSL_Enable/SSL_SetOptionJeffrey Stedfast2001-05-131-1/+1 * Decode Content-Location, either correctly or Netscape-generated-brokenly.Dan Winship2001-05-125-0/+64 * Don't check the initial auth response until we get into the while-loopJeffrey Stedfast2001-05-122-9/+20 * Make this return CamelStream * (like the other stream new functions)Dan Winship2001-05-123-5/+10 * call SSL_Enable after the SSL_ImportFD and before PR_Connect. Otherwise,Chris Toshok2001-05-112-1/+8 * Don't abort if the Service is NULL, this is perfectly valid for cipherJeffrey Stedfast2001-05-112-1/+5 * Pass appropriate parameters to CF_CLASS and add comment explaining why myPeter Williams2001-05-102-1/+9 * Set the disconnected status. (camel_disco_store_can_work_offline): ReturnDan Winship2001-05-1010-10/+308 * remove something jeff didn't mean to commitDan Winship2001-05-101-1/+1 * Wrap the content-id with <>'s.Jeffrey Stedfast2001-05-103-3/+17 * Add support for using OpenSSL.Jeffrey Stedfast2001-05-087-30/+109 * Fix another build problem. (Um, anyone else could have done this...)Dan Winship2001-05-062-1/+5 * Fix up refcounting on current_folder.Dan Winship2001-05-044-4/+14 * new abstract class for disconnectable remote storesDan Winship2001-05-0414-536/+1174 * Clean this up a bit. Add a "tag_prefix" member. Move "useful_lsub" intoDan Winship2001-05-034-18/+31 * Fix this up... it was losing count in some cases and giving a more verboseDan Winship2001-05-032-14/+12 * Rescue the KPOP code from bit rot.Dan Winship2001-05-022-23/+21 * Remove the last argument from camel_session_alert_user.Anders Carlsson2001-05-021-1/+1 * Redo command locking. Since command_lock is recursive, we can just get aDan Winship2001-05-027-197/+234 * remove unused assignment that calls non-existent function.Dan Winship2001-05-011-2/+0 * Support the IMAP UIDPLUS extension (RFC 2359), which lets youDan Winship2001-05-016-73/+469 * New-and-improved version of get_uid_set() from camel-imap-folder.c. LooksDan Winship2001-05-014-38/+89 * Redo this a lot so that instead of having a class full of callbacks, weDan Winship2001-04-2810-244/+361 * Automagically call camel_shutdown() atexit() ;-) (camel_init): AlsoJeffrey Stedfast2001-04-273-16/+25 * #include <sys/types.h> for off_t.Jeffrey Stedfast2001-04-272-0/+5 * #include "nss.h" rather than <nss.h> due to the non-mozilla nss.h file living...Jeffrey Stedfast2001-04-271-2/+3 * New file, with the int, string, time_t, and off_t encode/decode routinesDan Winship2001-04-279-363/+447 * Remove UNICODE_CFLAGS (and some other stuff that's redundant withDan Winship2001-04-2713-103/+83 * Use e_gethostbyname_r. (camel_service_gethost): Remove unused var.Dan Winship2001-04-272-9/+8 * Applied jacob's patches for e-poolv stuff.Not Zed2001-04-267-67/+122 * Add camel-vee-folder.h and camel-digest-folder.hJeffrey Stedfast2001-04-242-0/+4 * New class that can be used to browse a multipart/digest message as if itJeffrey Stedfast2001-04-245-1/+366 * Oops, don't use the return value of iconv() as a string length, it onlyJeffrey Stedfast2001-04-233-3/+10 * Changed GTK_INCLUDEDIR to EXTRA_GNOME_CFLAGS.Mikael Hallendal2001-04-232-1/+6 * Implemented using the secmime.h convenience functions. (smime_clearsign):Jeffrey Stedfast2001-04-214-15/+754 * Implemented. (pkcs7_clearsign): Implemented. (get_zero_len_passwd):Jeffrey Stedfast2001-04-202-5/+159 * Implemented. (pkcs7_clearsign): Implemented. (get_zero_len_passwd):Jeffrey Stedfast2001-04-202-7/+307 * missed this with the last commit (pop3 and imap memory leaks)Dan Winship2001-04-191-0/+14 * Free base_url and storage_path.Dan Winship2001-04-193-5/+33 * New source files to handle Pkcs7 encryption, decryption, signing, andJeffrey Stedfast2001-04-184-0/+330 * more memory leaksDan Winship2001-04-182-0/+7 * don't use g_return'sJeffrey Stedfast2001-04-171-2/+3 * Don't we want to tell where we are by using the start of the message? IJeffrey Stedfast2001-04-172-5/+14 * Added a prototype for stamp().Jeffrey Stedfast2001-04-174-1/+11 * Go back to doing the utf8 conversion by hand so that we don't depend onJeffrey Stedfast2001-04-172-4/+46 * oops, forgot to commit this with the last filesJeffrey Stedfast2001-04-171-1/+0 * Remove the EXTRA_GNOME_CFLAGS include.Jeffrey Stedfast2001-04-1711-21/+103 * eh?Jeffrey Stedfast2001-04-171-2/+0 * oops, &patternJeffrey Stedfast2001-04-161-2/+2 * regex doesn't set errno and regcomp returns 0 on success and any otherJeffrey Stedfast2001-04-162-5/+21 * Check to make sure the context is a valid context in all the userJeffrey Stedfast2001-04-152-0/+15 * s/imap_store/store/, fixing a typo that was causing the build to fail.Jon Trowbridge2001-04-142-5/+9 * Make the (previously unused) get-source command actually do the rightJon Trowbridge2001-04-143-4/+22 * Plug leaks.Dan Winship2001-04-14