aboutsummaryrefslogtreecommitdiffstats
path: root/lang/fpc-tcl/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'lang/fpc-tcl/Makefile')
-rw-r--r--lang/fpc-tcl/Makefile27
1 files changed, 24 insertions, 3 deletions
diff --git a/lang/fpc-tcl/Makefile b/lang/fpc-tcl/Makefile
index f7413dec34d0..c33b3c6c8803 100644
--- a/lang/fpc-tcl/Makefile
+++ b/lang/fpc-tcl/Makefile
@@ -8,12 +8,33 @@
CATEGORIES= lang
PKGNAMESUFFIX= -tcl
-MAINTAINER= acardenas@bsd.org.pe
+MAINTAINER= acm@FreeBSD.org
COMMENT= Free Pascal interface to the tcl/tk interpreter
-RUN_DEPENDS= ppc386:${PORTSDIR}/lang/fpc \
- wish8.4:${PORTSDIR}/x11-toolkits/tk84
+BUILD_DEPENDS= ppc386:${PORTSDIR}/lang/fpc \
+ fpcmake:${PORTSDIR}/lang/fpc-utils \
+ ${UNITSDIR}/fcl/Package.fpc:${PORTSDIR}/devel/fpc-fcl \
+ ${UNITSDIR}/gdbint/Package.fpc:${PORTSDIR}/devel/fpc-gdbint \
+ ${UNITSDIR}/ibase/Package.fpc:${PORTSDIR}/databases/fpc-ibase \
+ ${UNITSDIR}/libasync/Package.fpc:${PORTSDIR}/net/fpc-libasync \
+ ${UNITSDIR}/md5/Package.fpc:${PORTSDIR}/security/fpc-md5 \
+ ${UNITSDIR}/mysql/Package.fpc:${PORTSDIR}/databases/fpc-mysql \
+ ${UNITSDIR}/netdb/Package.fpc:${PORTSDIR}/net/fpc-netdb \
+ ${UNITSDIR}/odbc/Package.fpc:${PORTSDIR}/databases/fpc-odbc \
+ ${UNITSDIR}/oracle/Package.fpc:${PORTSDIR}/databases/fpc-oracle \
+ ${UNITSDIR}/pasjpeg/Package.fpc:${PORTSDIR}/graphics/fpc-pasjpeg \
+ ${UNITSDIR}/paszlib/Package.fpc:${PORTSDIR}/archivers/fpc-paszlib \
+ ${UNITSDIR}/pthreads/Package.fpc:${PORTSDIR}/devel/fpc-pthreads \
+ ${UNITSDIR}/postgres/Package.fpc:${PORTSDIR}/databases/fpc-postgres \
+ ${UNITSDIR}/regexpr/Package.fpc:${PORTSDIR}/devel/fpc-regexpr \
+ ${UNITSDIR}/sqlite/Package.fpc:${PORTSDIR}/databases/fpc-sqlite
+RUN_DEPENDS= wish8.4:${PORTSDIR}/x11-toolkits/tk84
+
+UNITSDIR= ${LOCALBASE}/lib/fpc/${PORTVERSION}/units/${BUILDNAME}
MASTERDIR= ${.CURDIR}/../../lang/fpc
+WRKUNITDIR= ${PORTNAME}/packages/extra/${PKGNAMESUFFIX:S/-//}
+EXTRACTUNITDIR+= ${WRKUNITDIR}
+HAVE_EXAMPLES= true
.include "${MASTERDIR}/Makefile"