aboutsummaryrefslogtreecommitdiffstats
path: root/lang/fth
diff options
context:
space:
mode:
Diffstat (limited to 'lang/fth')
-rw-r--r--lang/fth/Makefile27
-rw-r--r--lang/fth/distinfo3
-rw-r--r--lang/fth/pkg-descr6
-rw-r--r--lang/fth/pkg-plist43
4 files changed, 79 insertions, 0 deletions
diff --git a/lang/fth/Makefile b/lang/fth/Makefile
new file mode 100644
index 000000000000..f41779fcf735
--- /dev/null
+++ b/lang/fth/Makefile
@@ -0,0 +1,27 @@
+# $FreeBSD$
+
+PORTNAME= fth
+DISTVERSION= 1.3.8
+CATEGORIES= lang
+MASTER_SITES= SF/fth/fth/${DISTVERSION}/
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Forth interpreter and extension library
+
+LICENSE= BSD2CLAUSE
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+USES= gmake tar:bz2 ssl # ssl is used only for the bignum interface BN_*
+GNU_CONFIGURE= yes
+USE_LDCONFIG= yes
+INSTALL_TARGET= install-strip
+TEST_TARGET= test
+
+OPTIONS_DEFINE= TECLA
+OPTIONS_DEFAULT= TECLA
+TECLA_DESC= Use tecla command-line editing
+
+TECLA_CONFIGURE_WITH= tecla
+TECLA_LIB_DEPENDS= libtecla.so:devel/libtecla
+
+.include <bsd.port.mk>
diff --git a/lang/fth/distinfo b/lang/fth/distinfo
new file mode 100644
index 000000000000..f3080f603e6e
--- /dev/null
+++ b/lang/fth/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1517006393
+SHA256 (fth-1.3.8.tar.bz2) = 97047cdb9b7699d084206b6da46478c76f659ab9efc92248ac25f4ebf7bf1611
+SIZE (fth-1.3.8.tar.bz2) = 725254
diff --git a/lang/fth/pkg-descr b/lang/fth/pkg-descr
new file mode 100644
index 000000000000..a03d43ff768b
--- /dev/null
+++ b/lang/fth/pkg-descr
@@ -0,0 +1,6 @@
+Fth is a Forth language interpreter. It includes the interpreter itself, fth,
+and the extension library libfth. You can write Forth scripts and interpret them
+with the interpreter fth, or you can link libfth into an application to use it
+as extension language.
+
+WWW: https://sourceforge.net/projects/fth/
diff --git a/lang/fth/pkg-plist b/lang/fth/pkg-plist
new file mode 100644
index 000000000000..cb1958b86f8d
--- /dev/null
+++ b/lang/fth/pkg-plist
@@ -0,0 +1,43 @@
+bin/fth
+include/fth/ficl.h
+include/fth/ficllocal.h
+include/fth/ficltokens.h
+include/fth/fth-config.h
+include/fth/fth-lib.h
+include/fth/fth.h
+lib/fth/dbm.so
+lib/libfth.so
+man/man1/fth.1.gz
+man/man3/libfth.3.gz
+share/aclocal/fth.m4
+%%DATADIR%%/fth-lib/assert.fs
+%%DATADIR%%/fth-lib/compat.fs
+%%DATADIR%%/fth-lib/ficl.fr
+%%DATADIR%%/fth-lib/ficllocal.fr
+%%DATADIR%%/fth-lib/fileaccess.fr
+%%DATADIR%%/fth-lib/fth.fs
+%%DATADIR%%/fth-lib/ifbrack.fr
+%%DATADIR%%/fth-lib/jhlocal.fr
+%%DATADIR%%/fth-lib/marker.fr
+%%DATADIR%%/fth-lib/prefix.fr
+%%DATADIR%%/fth-lib/softcore.fr
+%%DATADIR%%/site-fth/bird.fsm
+%%DATADIR%%/site-fth/clm-ins.fs
+%%DATADIR%%/site-fth/clm.fs
+%%DATADIR%%/site-fth/draw.fs
+%%DATADIR%%/site-fth/dsp.fs
+%%DATADIR%%/site-fth/effects.fs
+%%DATADIR%%/site-fth/env.fs
+%%DATADIR%%/site-fth/enved.fs
+%%DATADIR%%/site-fth/examp.fs
+%%DATADIR%%/site-fth/extensions.fs
+%%DATADIR%%/site-fth/hooks.fs
+%%DATADIR%%/site-fth/marks.fs
+%%DATADIR%%/site-fth/mix.fs
+%%DATADIR%%/site-fth/popup.fs
+%%DATADIR%%/site-fth/rgb.fs
+%%DATADIR%%/site-fth/rubber.fs
+%%DATADIR%%/site-fth/snd-forth-init.fs
+%%DATADIR%%/site-fth/snd-xm.fs
+%%DATADIR%%/site-fth/spectr.fs
+%%DATADIR%%/site-fth/xm-enved.fs