aboutsummaryrefslogtreecommitdiffstats
path: root/lang/gcc46/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'lang/gcc46/Makefile')
-rw-r--r--lang/gcc46/Makefile11
1 files changed, 8 insertions, 3 deletions
diff --git a/lang/gcc46/Makefile b/lang/gcc46/Makefile
index d8487bef6028..a4a8f5347454 100644
--- a/lang/gcc46/Makefile
+++ b/lang/gcc46/Makefile
@@ -28,9 +28,6 @@ LIB_DEPENDS= gmp.7:${PORTSDIR}/math/libgmp4 \
SUFFIX= 44
LATEST_LINK?= gcc${SUFFIX}${PKGNAMESUFFIX}
NOT_FOR_ARCHS= alpha ia64
-# Building libgcj with lang/gcc295 installed is causing a failure about
-# "hidden symbol `__eprintf'" in libgcc.a(_eprintf.o).
-CONFLICTS= gcc-2.95.*
USE_BISON= build
USE_BZIP2= yes
USE_GMAKE= yes
@@ -150,6 +147,14 @@ pre-everything::
fi
.endif
+pre-extract:
+ @# Building libgcj with lang/gcc295 installed is causing a failure
+ @# about "hidden symbol `__eprintf'" in libgcc.a(_eprintf.o).
+ @if type gcc295 >/dev/null ; then \
+ echo "This port will not build in the presence of lang/gcc295."; \
+ exit 1; \
+ fi
+
post-patch:
@${REINPLACE_CMD} -e 's|\(const char version_string.*\)";|\1 [FreeBSD]";|' \
${SRCDIR}/gcc/version.c