aboutsummaryrefslogtreecommitdiffstats
path: root/lang/io/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'lang/io/Makefile')
-rw-r--r--lang/io/Makefile7
1 files changed, 3 insertions, 4 deletions
diff --git a/lang/io/Makefile b/lang/io/Makefile
index 9b3d948f9568..95600a11e386 100644
--- a/lang/io/Makefile
+++ b/lang/io/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= io
-PORTVERSION= 2013.12.04
-PORTREVISION= 5
+PORTVERSION= 2015.11.11
CATEGORIES= lang
MAINTAINER= ports@FreeBSD.org
@@ -15,8 +14,7 @@ USE_GITHUB= yes
GH_ACCOUNT= stevedekorte
GH_TAGNAME= 23afbcc
-USES= cmake:outsource
-USE_GCC= yes
+USES= cmake:outsource compiler:c11
MAKE_JOBS_UNSAFE=yes
USE_LDCONFIG= yes
@@ -32,6 +30,7 @@ OPTIONS_SUB= yes
post-patch:
${REINPLACE_CMD} -e 's/^[ ]*add_subdirectory/#&/' \
${WRKSRC}/addons/CMakeLists.txt
+ ${RM} ${WRKSRC}/modules/FindFreetype.cmake
.for addon in ${ADDONS}
${ECHO} "add_subdirectory(${addon})" >> ${WRKSRC}/addons/CMakeLists.txt
.endfor