aboutsummaryrefslogtreecommitdiffstats
path: root/lang/moscow_ml
diff options
context:
space:
mode:
Diffstat (limited to 'lang/moscow_ml')
-rw-r--r--lang/moscow_ml/Makefile35
-rw-r--r--lang/moscow_ml/pkg-plist422
2 files changed, 228 insertions, 229 deletions
diff --git a/lang/moscow_ml/Makefile b/lang/moscow_ml/Makefile
index 4d7845664041..108f287e5e75 100644
--- a/lang/moscow_ml/Makefile
+++ b/lang/moscow_ml/Makefile
@@ -3,7 +3,7 @@
PORTNAME= moscow_ml
PORTVERSION= 2.01
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= lang
MASTER_SITES= http://www.itu.dk/~sestoft/mosml/
DISTNAME= mos201src
@@ -11,8 +11,8 @@ DISTNAME= mos201src
MAINTAINER= johans@FreeBSD.org
COMMENT= Lightweight implementation of Standard ML
-LIB_DEPENDS= gmp:${PORTSDIR}/math/gmp \
- gdbm:${PORTSDIR}/databases/gdbm
+LIB_DEPENDS= libgmp.so:${PORTSDIR}/math/gmp \
+ libgdbm.so:${PORTSDIR}/databases/gdbm
RESTRICTED= Restrictions on for-profit distribution
@@ -41,6 +41,8 @@ post-patch: .SILENT
${REINPLACE_CMD} -e "s,/usr/local,${PREFIX}," \
${WRKSRC}/dynlibs/crypt/Makefile \
${WRKSRC}/dynlibs/interface/Makefile
+ ${REINPLACE_CMD} -e '/ln -s/s|$$(BINDIR)|../../bin|' \
+ ${WRKSRC}/mosmllib/Makefile
# Fix inner makefiles and configure script to make port jobs (-jX) safe
${REINPLACE_CMD} -e '2s,^,cd "$$1" || exit 1 ; shift,' \
${WRKSRC}/config/autoconf
@@ -49,23 +51,20 @@ post-patch: .SILENT
${FIND} ${WRKSRC} -type f -name Makefile -print0 | ${XARGS} -0 \
${REINPLACE_CMD} -E 's|cd (.+); make|$$(MAKE) -C \1|'
-NO_STAGE= yes
post-install:
- ${INSTALL_DATA} ${WRKDIR}/mosml/copyrght/copyrght.att ${DOCSDIR}
- ${INSTALL_DATA} ${WRKDIR}/mosml/copyrght/copyrght.cl ${DOCSDIR}
- ${INSTALL_DATA} ${WRKDIR}/mosml/copyrght/gpl2 ${DOCSDIR}
- ${INSTALL_DATA} ${WRKDIR}/mosml/README ${DOCSDIR}
- ${INSTALL_DATA} ${PKGMESSAGE} ${DOCSDIR}/README.FreeBSD
- ${CHOWN} -R ${SHAREOWN}:${SHAREGRP} "${DOCSDIR}"
- @${MKDIR} ${EXAMPLESDIR}
- ${INSTALL_DATA} ${WRKDIR}/mosml/tools/Makefile.stub ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKDIR}/mosml/copyrght/copyrght.att \
+ ${WRKDIR}/mosml/copyrght/copyrght.cl \
+ ${WRKDIR}/mosml/copyrght/gpl2 \
+ ${WRKDIR}/mosml/README ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PKGMESSAGE} ${STAGEDIR}${DOCSDIR}/README.FreeBSD
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKDIR}/mosml/tools/Makefile.stub ${STAGEDIR}${EXAMPLESDIR}
cd ${WRKDIR}/mosml/examples && ${TAR} -cf - --dereference \
--exclude=\*.orig --exclude=\*.bak --exclude=\*.w32 * | \
- ${TAR} -xf - -C "${EXAMPLESDIR}"
- ${CHOWN} -R ${SHAREOWN}:${SHAREGRP} "${EXAMPLESDIR}"
- @${FIND} ${EXAMPLESDIR} -type f -exec ${CHMOD} ${SHAREMODE} {} \;
- @${ECHO_MSG}
- @${CAT} ${PKGMESSAGE}
- @${ECHO_MSG}
+ ${TAR} -xf - -C "${STAGEDIR}${EXAMPLESDIR}"
+ @${FIND} ${STAGEDIR}${EXAMPLESDIR} -type f -exec ${CHMOD} ${SHAREMODE} {} \;
+ @${REINPLACE_CMD} -i '' -e 's|${STAGEDIR}||' \
+ ${STAGEDIR}${PREFIX}/lib/mosml/header
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/mosml/lib*.so
.include <bsd.port.mk>
diff --git a/lang/moscow_ml/pkg-plist b/lang/moscow_ml/pkg-plist
index 482baab33114..e63fb9aa9c36 100644
--- a/lang/moscow_ml/pkg-plist
+++ b/lang/moscow_ml/pkg-plist
@@ -1,191 +1,3 @@
-%%DOCSDIR%%/README
-%%DOCSDIR%%/README.FreeBSD
-%%DOCSDIR%%/copyrght.att
-%%DOCSDIR%%/copyrght.cl
-%%DOCSDIR%%/gpl2
-%%EXAMPLESDIR%%/Makefile
-%%EXAMPLESDIR%%/README
-%%EXAMPLESDIR%%/calc/Lexer.lex
-%%EXAMPLESDIR%%/calc/Makefile
-%%EXAMPLESDIR%%/calc/Parser.grm
-%%EXAMPLESDIR%%/calc/calc.sml
-%%EXAMPLESDIR%%/cgi/Makefile
-%%EXAMPLESDIR%%/cgi/README
-%%EXAMPLESDIR%%/cgi/README1
-%%EXAMPLESDIR%%/cgi/README2
-%%EXAMPLESDIR%%/cgi/cgiex1.sml
-%%EXAMPLESDIR%%/cgi/cgiex2.sml
-%%EXAMPLESDIR%%/cgi/cgitest.sml
-%%EXAMPLESDIR%%/cgi/htmlform.html
-%%EXAMPLESDIR%%/cgi/upload.html
-%%EXAMPLESDIR%%/lexyacc/Data.sml
-%%EXAMPLESDIR%%/lexyacc/Lexer.lex
-%%EXAMPLESDIR%%/lexyacc/Main.sml
-%%EXAMPLESDIR%%/lexyacc/Makefile
-%%EXAMPLESDIR%%/lexyacc/Parser.grm
-%%EXAMPLESDIR%%/lexyacc/README
-%%EXAMPLESDIR%%/lexyacc/cl/append.cl
-%%EXAMPLESDIR%%/lexyacc/cl/edigits.cl
-%%EXAMPLESDIR%%/lexyacc/cl/error1.cl
-%%EXAMPLESDIR%%/lexyacc/cl/error2.cl
-%%EXAMPLESDIR%%/lexyacc/cl/error3.cl
-%%EXAMPLESDIR%%/lexyacc/cl/fib.cl
-%%EXAMPLESDIR%%/lexyacc/cl/fibs.cl
-%%EXAMPLESDIR%%/lexyacc/cl/hamming.cl
-%%EXAMPLESDIR%%/lexyacc/cl/lists.cl
-%%EXAMPLESDIR%%/lexyacc/cl/nats.cl
-%%EXAMPLESDIR%%/lexyacc/cl/sieve.cl
-%%EXAMPLESDIR%%/lexyacc/cl/takefrom.cl
-%%EXAMPLESDIR%%/lexyacc/load
-%%EXAMPLESDIR%%/manual/Evaluate.sig
-%%EXAMPLESDIR%%/manual/Evaluate.sml
-%%EXAMPLESDIR%%/manual/Expr.sml
-%%EXAMPLESDIR%%/manual/Makefile
-%%EXAMPLESDIR%%/manual/Reduce.sig
-%%EXAMPLESDIR%%/manual/Reduce.sml
-%%EXAMPLESDIR%%/manual/load
-%%EXAMPLESDIR%%/mls/Makefile
-%%EXAMPLESDIR%%/mls/mls.sml
-%%EXAMPLESDIR%%/modules/README
-%%EXAMPLESDIR%%/modules/array.sml
-%%EXAMPLESDIR%%/modules/bootstrap.sml
-%%EXAMPLESDIR%%/modules/choice.sml
-%%EXAMPLESDIR%%/modules/collect.sml
-%%EXAMPLESDIR%%/modules/matrix.sml
-%%EXAMPLESDIR%%/modules/poly.sml
-%%EXAMPLESDIR%%/modules/recursion.sml
-%%EXAMPLESDIR%%/modules/sieve.sml
-%%EXAMPLESDIR%%/parsercomb/Makefile
-%%EXAMPLESDIR%%/parsercomb/Parsercomb.sig
-%%EXAMPLESDIR%%/parsercomb/Parsercomb.sml
-%%EXAMPLESDIR%%/parsercomb/README
-%%EXAMPLESDIR%%/paulson/README
-%%EXAMPLESDIR%%/paulson/sample.sml
-%%EXAMPLESDIR%%/paulson/sample10.sml
-%%EXAMPLESDIR%%/paulson/sample2.sml
-%%EXAMPLESDIR%%/paulson/sample3.sml
-%%EXAMPLESDIR%%/paulson/sample4.sml
-%%EXAMPLESDIR%%/paulson/sample5.sml
-%%EXAMPLESDIR%%/paulson/sample7.sml
-%%EXAMPLESDIR%%/paulson/sample8.sml
-%%EXAMPLESDIR%%/paulson/sample9.sml
-%%EXAMPLESDIR%%/paulson/test10.sml
-%%EXAMPLESDIR%%/pretty/Makefile
-%%EXAMPLESDIR%%/pretty/ppexpr.sml
-%%EXAMPLESDIR%%/pretty/pproman.sml
-%%EXAMPLESDIR%%/small/README
-%%EXAMPLESDIR%%/small/countperms.sml
-%%EXAMPLESDIR%%/small/countqueens.sml
-%%EXAMPLESDIR%%/small/perms.sml
-%%EXAMPLESDIR%%/small/queens.sml
-%%EXAMPLESDIR%%/small/roman.sml
-%%EXAMPLESDIR%%/small/subsets.sml
-%%EXAMPLESDIR%%/small/subsum.sml
-%%EXAMPLESDIR%%/units/Evaluate.sig
-%%EXAMPLESDIR%%/units/Evaluate.sm
-%%EXAMPLESDIR%%/units/Evaluate.sml
-%%EXAMPLESDIR%%/units/Expr.sml
-%%EXAMPLESDIR%%/units/Makefile
-%%EXAMPLESDIR%%/units/Reduce.sig
-%%EXAMPLESDIR%%/units/Reduce.sml
-%%EXAMPLESDIR%%/units/Test.sml
-%%EXAMPLESDIR%%/units/load
-%%EXAMPLESDIR%%/weak/Makefile
-%%EXAMPLESDIR%%/weak/README
-%%EXAMPLESDIR%%/weak/hashcons.sml
-%%EXAMPLESDIR%%/webserver/Makefile
-%%EXAMPLESDIR%%/webserver/README
-%%EXAMPLESDIR%%/webserver/echoserver.sml
-%%EXAMPLESDIR%%/webserver/minimalserver.sml
-%%EXAMPLESDIR%%/webserver/mosmlserver.sml
-%%EXAMPLESDIR%%/webserver/useit.sml
-%%EXAMPLESDIR%%/Makefile.stub
-%%EXAMPLESDIR%%/ffi/crypt/Makefile
-%%EXAMPLESDIR%%/ffi/crypt/README
-%%EXAMPLESDIR%%/ffi/crypt/crypt.c
-%%EXAMPLESDIR%%/ffi/crypt/crypt.sml
-%%EXAMPLESDIR%%/ffi/interface/Makefile
-%%EXAMPLESDIR%%/ffi/interface/cside.c
-%%EXAMPLESDIR%%/ffi/interface/result.mac
-%%EXAMPLESDIR%%/ffi/interface/smlside.sml
-%%EXAMPLESDIR%%/ffi/interface/smlside_mac.sml
-%%PORTDOCS%%%%DOCSDIR%%/manual.pdf
-%%PORTDOCS%%%%DOCSDIR%%/mosmllib.pdf
-%%PORTDOCS%%%%DOCSDIR%%/mosmllib/AppleScript.html
-%%PORTDOCS%%%%DOCSDIR%%/mosmllib/Array.html
-%%PORTDOCS%%%%DOCSDIR%%/mosmllib/Array2.html
-%%PORTDOCS%%%%DOCSDIR%%/mosmllib/Arraysort.html
-%%PORTDOCS%%%%DOCSDIR%%/mosmllib/BasicIO.html
-%%PORTDOCS%%%%DOCSDIR%%/mosmllib/BinIO.html
-%%PORTDOCS%%%%DOCSDIR%%/mosmllib/Binarymap.html
-%%PORTDOCS%%%%DOCSDIR%%/mosmllib/Binaryset.html
-%%PORTDOCS%%%%DOCSDIR%%/mosmllib/Bool.html
-%%PORTDOCS%%%%DOCSDIR%%/mosmllib/Byte.html
-%%PORTDOCS%%%%DOCSDIR%%/mosmllib/Callback.html
-%%PORTDOCS%%%%DOCSDIR%%/mosmllib/Char.html
-%%PORTDOCS%%%%DOCSDIR%%/mosmllib/CharArray.html
-%%PORTDOCS%%%%DOCSDIR%%/mosmllib/CharVector.html
-%%PORTDOCS%%%%DOCSDIR%%/mosmllib/CommandLine.html
-%%PORTDOCS%%%%DOCSDIR%%/mosmllib/Date.html
-%%PORTDOCS%%%%DOCSDIR%%/mosmllib/Dynarray.html
-%%PORTDOCS%%%%DOCSDIR%%/mosmllib/Dynlib.html
-%%PORTDOCS%%%%DOCSDIR%%/mosmllib/FileSys.html
-%%PORTDOCS%%%%DOCSDIR%%/mosmllib/Gdbm.html
-%%PORTDOCS%%%%DOCSDIR%%/mosmllib/Gdimage.html
-%%PORTDOCS%%%%DOCSDIR%%/mosmllib/General.html
-%%PORTDOCS%%%%DOCSDIR%%/mosmllib/Help.html
-%%PORTDOCS%%%%DOCSDIR%%/mosmllib/Int.html
-%%PORTDOCS%%%%DOCSDIR%%/mosmllib/Intmap.html
-%%PORTDOCS%%%%DOCSDIR%%/mosmllib/Intset.html
-%%PORTDOCS%%%%DOCSDIR%%/mosmllib/Lexing.html
-%%PORTDOCS%%%%DOCSDIR%%/mosmllib/List.html
-%%PORTDOCS%%%%DOCSDIR%%/mosmllib/ListPair.html
-%%PORTDOCS%%%%DOCSDIR%%/mosmllib/Listsort.html
-%%PORTDOCS%%%%DOCSDIR%%/mosmllib/Location.html
-%%PORTDOCS%%%%DOCSDIR%%/mosmllib/Math.html
-%%PORTDOCS%%%%DOCSDIR%%/mosmllib/Meta.html
-%%PORTDOCS%%%%DOCSDIR%%/mosmllib/Mosml.html
-%%PORTDOCS%%%%DOCSDIR%%/mosmllib/Mosmlcgi.html
-%%PORTDOCS%%%%DOCSDIR%%/mosmllib/Mosmlcookie.html
-%%PORTDOCS%%%%DOCSDIR%%/mosmllib/Msp.html
-%%PORTDOCS%%%%DOCSDIR%%/mosmllib/Mysql.html
-%%PORTDOCS%%%%DOCSDIR%%/mosmllib/NJ93.html
-%%PORTDOCS%%%%DOCSDIR%%/mosmllib/Nonstdio.html
-%%PORTDOCS%%%%DOCSDIR%%/mosmllib/OS.html
-%%PORTDOCS%%%%DOCSDIR%%/mosmllib/Option.html
-%%PORTDOCS%%%%DOCSDIR%%/mosmllib/PP.html
-%%PORTDOCS%%%%DOCSDIR%%/mosmllib/Parsing.html
-%%PORTDOCS%%%%DOCSDIR%%/mosmllib/Path.html
-%%PORTDOCS%%%%DOCSDIR%%/mosmllib/Polygdbm.html
-%%PORTDOCS%%%%DOCSDIR%%/mosmllib/Polyhash.html
-%%PORTDOCS%%%%DOCSDIR%%/mosmllib/Postgres.html
-%%PORTDOCS%%%%DOCSDIR%%/mosmllib/Process.html
-%%PORTDOCS%%%%DOCSDIR%%/mosmllib/Random.html
-%%PORTDOCS%%%%DOCSDIR%%/mosmllib/Real.html
-%%PORTDOCS%%%%DOCSDIR%%/mosmllib/Regex.html
-%%PORTDOCS%%%%DOCSDIR%%/mosmllib/SML90.html
-%%PORTDOCS%%%%DOCSDIR%%/mosmllib/Signal.html
-%%PORTDOCS%%%%DOCSDIR%%/mosmllib/Socket.html
-%%PORTDOCS%%%%DOCSDIR%%/mosmllib/Splaymap.html
-%%PORTDOCS%%%%DOCSDIR%%/mosmllib/Splayset.html
-%%PORTDOCS%%%%DOCSDIR%%/mosmllib/String.html
-%%PORTDOCS%%%%DOCSDIR%%/mosmllib/StringCvt.html
-%%PORTDOCS%%%%DOCSDIR%%/mosmllib/Substring.html
-%%PORTDOCS%%%%DOCSDIR%%/mosmllib/Susp.html
-%%PORTDOCS%%%%DOCSDIR%%/mosmllib/TextIO.html
-%%PORTDOCS%%%%DOCSDIR%%/mosmllib/Time.html
-%%PORTDOCS%%%%DOCSDIR%%/mosmllib/Timer.html
-%%PORTDOCS%%%%DOCSDIR%%/mosmllib/Unix.html
-%%PORTDOCS%%%%DOCSDIR%%/mosmllib/Vector.html
-%%PORTDOCS%%%%DOCSDIR%%/mosmllib/Weak.html
-%%PORTDOCS%%%%DOCSDIR%%/mosmllib/Word.html
-%%PORTDOCS%%%%DOCSDIR%%/mosmllib/Word8.html
-%%PORTDOCS%%%%DOCSDIR%%/mosmllib/Word8Array.html
-%%PORTDOCS%%%%DOCSDIR%%/mosmllib/Word8Vector.html
-%%PORTDOCS%%%%DOCSDIR%%/mosmllib/idIndex.html
-%%PORTDOCS%%%%DOCSDIR%%/mosmllib/index.html
-%%PORTDOCS%%%%DOCSDIR%%/mosmllib2up.pdf
-%%PORTDOCS%%%%DOCSDIR%%/mosmlref.pdf
bin/camlrunm
bin/mosml
bin/mosmlc
@@ -464,26 +276,214 @@ lib/mosml/mosmllnk
lib/mosml/mosmltop
libexec/mosml/cutdeps
libexec/mosml/mosmldep
-%%PORTDOCS%%@dirrm share/doc/moscow_ml/mosmllib
-@dirrm %%EXAMPLESDIR%%/calc
-@dirrm %%EXAMPLESDIR%%/cgi
-@dirrm %%EXAMPLESDIR%%/ffi/interface
-@dirrm %%EXAMPLESDIR%%/ffi/crypt
-@dirrm %%EXAMPLESDIR%%/ffi
-@dirrm %%EXAMPLESDIR%%/lexyacc/cl
-@dirrm %%EXAMPLESDIR%%/lexyacc
-@dirrm %%EXAMPLESDIR%%/manual
-@dirrm %%EXAMPLESDIR%%/mls
-@dirrm %%EXAMPLESDIR%%/modules
-@dirrm %%EXAMPLESDIR%%/parsercomb
-@dirrm %%EXAMPLESDIR%%/paulson
-@dirrm %%EXAMPLESDIR%%/pretty
-@dirrm %%EXAMPLESDIR%%/small
-@dirrm %%EXAMPLESDIR%%/units
-@dirrm %%EXAMPLESDIR%%/weak
-@dirrm %%EXAMPLESDIR%%/webserver
-@dirrm %%EXAMPLESDIR%%
-@dirrm %%DOCSDIR%%
-@dirrm include/mosml
-@dirrm libexec/mosml
-@dirrm lib/mosml
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/README.FreeBSD
+%%PORTDOCS%%%%DOCSDIR%%/copyrght.att
+%%PORTDOCS%%%%DOCSDIR%%/copyrght.cl
+%%PORTDOCS%%%%DOCSDIR%%/gpl2
+%%PORTDOCS%%%%DOCSDIR%%/manual.pdf
+%%PORTDOCS%%%%DOCSDIR%%/mosmllib.pdf
+%%PORTDOCS%%%%DOCSDIR%%/mosmllib/AppleScript.html
+%%PORTDOCS%%%%DOCSDIR%%/mosmllib/Array.html
+%%PORTDOCS%%%%DOCSDIR%%/mosmllib/Array2.html
+%%PORTDOCS%%%%DOCSDIR%%/mosmllib/Arraysort.html
+%%PORTDOCS%%%%DOCSDIR%%/mosmllib/BasicIO.html
+%%PORTDOCS%%%%DOCSDIR%%/mosmllib/BinIO.html
+%%PORTDOCS%%%%DOCSDIR%%/mosmllib/Binarymap.html
+%%PORTDOCS%%%%DOCSDIR%%/mosmllib/Binaryset.html
+%%PORTDOCS%%%%DOCSDIR%%/mosmllib/Bool.html
+%%PORTDOCS%%%%DOCSDIR%%/mosmllib/Byte.html
+%%PORTDOCS%%%%DOCSDIR%%/mosmllib/Callback.html
+%%PORTDOCS%%%%DOCSDIR%%/mosmllib/Char.html
+%%PORTDOCS%%%%DOCSDIR%%/mosmllib/CharArray.html
+%%PORTDOCS%%%%DOCSDIR%%/mosmllib/CharVector.html
+%%PORTDOCS%%%%DOCSDIR%%/mosmllib/CommandLine.html
+%%PORTDOCS%%%%DOCSDIR%%/mosmllib/Date.html
+%%PORTDOCS%%%%DOCSDIR%%/mosmllib/Dynarray.html
+%%PORTDOCS%%%%DOCSDIR%%/mosmllib/Dynlib.html
+%%PORTDOCS%%%%DOCSDIR%%/mosmllib/FileSys.html
+%%PORTDOCS%%%%DOCSDIR%%/mosmllib/Gdbm.html
+%%PORTDOCS%%%%DOCSDIR%%/mosmllib/Gdimage.html
+%%PORTDOCS%%%%DOCSDIR%%/mosmllib/General.html
+%%PORTDOCS%%%%DOCSDIR%%/mosmllib/Help.html
+%%PORTDOCS%%%%DOCSDIR%%/mosmllib/Int.html
+%%PORTDOCS%%%%DOCSDIR%%/mosmllib/Intmap.html
+%%PORTDOCS%%%%DOCSDIR%%/mosmllib/Intset.html
+%%PORTDOCS%%%%DOCSDIR%%/mosmllib/Lexing.html
+%%PORTDOCS%%%%DOCSDIR%%/mosmllib/List.html
+%%PORTDOCS%%%%DOCSDIR%%/mosmllib/ListPair.html
+%%PORTDOCS%%%%DOCSDIR%%/mosmllib/Listsort.html
+%%PORTDOCS%%%%DOCSDIR%%/mosmllib/Location.html
+%%PORTDOCS%%%%DOCSDIR%%/mosmllib/Math.html
+%%PORTDOCS%%%%DOCSDIR%%/mosmllib/Meta.html
+%%PORTDOCS%%%%DOCSDIR%%/mosmllib/Mosml.html
+%%PORTDOCS%%%%DOCSDIR%%/mosmllib/Mosmlcgi.html
+%%PORTDOCS%%%%DOCSDIR%%/mosmllib/Mosmlcookie.html
+%%PORTDOCS%%%%DOCSDIR%%/mosmllib/Msp.html
+%%PORTDOCS%%%%DOCSDIR%%/mosmllib/Mysql.html
+%%PORTDOCS%%%%DOCSDIR%%/mosmllib/NJ93.html
+%%PORTDOCS%%%%DOCSDIR%%/mosmllib/Nonstdio.html
+%%PORTDOCS%%%%DOCSDIR%%/mosmllib/OS.html
+%%PORTDOCS%%%%DOCSDIR%%/mosmllib/Option.html
+%%PORTDOCS%%%%DOCSDIR%%/mosmllib/PP.html
+%%PORTDOCS%%%%DOCSDIR%%/mosmllib/Parsing.html
+%%PORTDOCS%%%%DOCSDIR%%/mosmllib/Path.html
+%%PORTDOCS%%%%DOCSDIR%%/mosmllib/Polygdbm.html
+%%PORTDOCS%%%%DOCSDIR%%/mosmllib/Polyhash.html
+%%PORTDOCS%%%%DOCSDIR%%/mosmllib/Postgres.html
+%%PORTDOCS%%%%DOCSDIR%%/mosmllib/Process.html
+%%PORTDOCS%%%%DOCSDIR%%/mosmllib/Random.html
+%%PORTDOCS%%%%DOCSDIR%%/mosmllib/Real.html
+%%PORTDOCS%%%%DOCSDIR%%/mosmllib/Regex.html
+%%PORTDOCS%%%%DOCSDIR%%/mosmllib/SML90.html
+%%PORTDOCS%%%%DOCSDIR%%/mosmllib/Signal.html
+%%PORTDOCS%%%%DOCSDIR%%/mosmllib/Socket.html
+%%PORTDOCS%%%%DOCSDIR%%/mosmllib/Splaymap.html
+%%PORTDOCS%%%%DOCSDIR%%/mosmllib/Splayset.html
+%%PORTDOCS%%%%DOCSDIR%%/mosmllib/String.html
+%%PORTDOCS%%%%DOCSDIR%%/mosmllib/StringCvt.html
+%%PORTDOCS%%%%DOCSDIR%%/mosmllib/Substring.html
+%%PORTDOCS%%%%DOCSDIR%%/mosmllib/Susp.html
+%%PORTDOCS%%%%DOCSDIR%%/mosmllib/TextIO.html
+%%PORTDOCS%%%%DOCSDIR%%/mosmllib/Time.html
+%%PORTDOCS%%%%DOCSDIR%%/mosmllib/Timer.html
+%%PORTDOCS%%%%DOCSDIR%%/mosmllib/Unix.html
+%%PORTDOCS%%%%DOCSDIR%%/mosmllib/Vector.html
+%%PORTDOCS%%%%DOCSDIR%%/mosmllib/Weak.html
+%%PORTDOCS%%%%DOCSDIR%%/mosmllib/Word.html
+%%PORTDOCS%%%%DOCSDIR%%/mosmllib/Word8.html
+%%PORTDOCS%%%%DOCSDIR%%/mosmllib/Word8Array.html
+%%PORTDOCS%%%%DOCSDIR%%/mosmllib/Word8Vector.html
+%%PORTDOCS%%%%DOCSDIR%%/mosmllib/idIndex.html
+%%PORTDOCS%%%%DOCSDIR%%/mosmllib/index.html
+%%PORTDOCS%%%%DOCSDIR%%/mosmllib2up.pdf
+%%PORTDOCS%%%%DOCSDIR%%/mosmlref.pdf
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/Makefile
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/Makefile.stub
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/README
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/calc/Lexer.lex
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/calc/Makefile
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/calc/Parser.grm
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/calc/calc.sml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/cgi/Makefile
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/cgi/README
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/cgi/README1
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/cgi/README2
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/cgi/cgiex1.sml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/cgi/cgiex2.sml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/cgi/cgitest.sml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/cgi/htmlform.html
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/cgi/upload.html
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ffi/crypt/Makefile
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ffi/crypt/README
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ffi/crypt/crypt.c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ffi/crypt/crypt.sml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ffi/interface/Makefile
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ffi/interface/cside.c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ffi/interface/result.mac
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ffi/interface/smlside.sml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ffi/interface/smlside_mac.sml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/lexyacc/Data.sml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/lexyacc/Lexer.lex
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/lexyacc/Main.sml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/lexyacc/Makefile
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/lexyacc/Parser.grm
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/lexyacc/README
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/lexyacc/cl/append.cl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/lexyacc/cl/edigits.cl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/lexyacc/cl/error1.cl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/lexyacc/cl/error2.cl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/lexyacc/cl/error3.cl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/lexyacc/cl/fib.cl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/lexyacc/cl/fibs.cl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/lexyacc/cl/hamming.cl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/lexyacc/cl/lists.cl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/lexyacc/cl/nats.cl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/lexyacc/cl/sieve.cl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/lexyacc/cl/takefrom.cl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/lexyacc/load
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/manual/Evaluate.sig
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/manual/Evaluate.sml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/manual/Expr.sml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/manual/Makefile
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/manual/Reduce.sig
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/manual/Reduce.sml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/manual/load
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/mls/Makefile
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/mls/mls.sml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/modules/README
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/modules/array.sml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/modules/bootstrap.sml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/modules/choice.sml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/modules/collect.sml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/modules/matrix.sml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/modules/poly.sml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/modules/recursion.sml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/modules/sieve.sml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/parsercomb/Makefile
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/parsercomb/Parsercomb.sig
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/parsercomb/Parsercomb.sml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/parsercomb/README
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/paulson/README
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/paulson/sample.sml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/paulson/sample10.sml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/paulson/sample2.sml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/paulson/sample3.sml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/paulson/sample4.sml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/paulson/sample5.sml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/paulson/sample7.sml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/paulson/sample8.sml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/paulson/sample9.sml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/paulson/test10.sml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/pretty/Makefile
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/pretty/ppexpr.sml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/pretty/pproman.sml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/small/README
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/small/countperms.sml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/small/countqueens.sml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/small/perms.sml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/small/queens.sml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/small/roman.sml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/small/subsets.sml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/small/subsum.sml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/units/Evaluate.sig
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/units/Evaluate.sm
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/units/Evaluate.sml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/units/Expr.sml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/units/Makefile
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/units/Reduce.sig
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/units/Reduce.sml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/units/Test.sml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/units/load
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/weak/Makefile
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/weak/README
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/weak/hashcons.sml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/webserver/Makefile
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/webserver/README
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/webserver/echoserver.sml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/webserver/minimalserver.sml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/webserver/mosmlserver.sml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/webserver/useit.sml
+%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%/webserver
+%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%/weak
+%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%/units
+%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%/small
+%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%/pretty
+%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%/paulson
+%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%/parsercomb
+%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%/modules
+%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%/mls
+%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%/manual
+%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%/lexyacc/cl
+%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%/lexyacc
+%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%/ffi/interface
+%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%/ffi/crypt
+%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%/ffi
+%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%/cgi
+%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%/calc
+%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%
+%%PORTDOCS%%@dirrmtry %%DOCSDIR%%/mosmllib
+%%PORTDOCS%%@dirrmtry %%DOCSDIR%%
+@dirrmtry libexec/mosml
+@dirrmtry lib/mosml
+@dirrmtry include/mosml