aboutsummaryrefslogtreecommitdiffstats
path: root/lang/ocaml-examples/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'lang/ocaml-examples/Makefile')
-rw-r--r--lang/ocaml-examples/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/lang/ocaml-examples/Makefile b/lang/ocaml-examples/Makefile
new file mode 100644
index 000000000000..2b293d7c89fa
--- /dev/null
+++ b/lang/ocaml-examples/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: ocaml-examples
+# Date created: 2006-07-27
+# Whom: Stanislav Sedov <ssedov@mbsd.msk.ru>
+#
+# $MBSDlabs$
+# $FreeBSD$
+#
+
+PORTNAME= ocaml
+PORTVERSION= 3.08
+CATEGORIES= lang
+MASTER_SITES= http://caml.inria.fr/distrib/ \
+ ftp://ftp.inria.fr/INRIA/caml-light/ \
+ ftp://ftp.kurims.kyoto-u.ac.jp/pub/lang/caml-light/
+PKGNAMESUFFIX= -examples
+DISTNAME= ${PORTNAME}${PKGNAMESUFFIX}-${PORTVERSION}
+
+MAINTAINER= ssedov@mbsd.msk.ru
+COMMENT= Example programs for the Objective Caml
+
+NO_BUILD= yes
+
+do-install:
+ @${MKDIR} ${EXAMPLESDIR}
+ @${TAR} -cf- -C ${WRKSRC} --exclude Makefile --exclude Imakefile . | \
+ ${TAR} -xf- -C ${EXAMPLESDIR}
+ @${FIND} ${EXAMPLESDIR} -type f -exec ${CHMOD} ${SHAREMODE} {} \;
+ @${FIND} ${EXAMPLESDIR} -exec ${CHOWN} ${SHAREOWN} {} \;
+
+.include <bsd.port.mk>