aboutsummaryrefslogtreecommitdiffstats
path: root/lang/php4
diff options
context:
space:
mode:
Diffstat (limited to 'lang/php4')
-rw-r--r--lang/php4/Makefile.ext4
1 files changed, 4 insertions, 0 deletions
diff --git a/lang/php4/Makefile.ext b/lang/php4/Makefile.ext
index ca0464e673ef..002a91252647 100644
--- a/lang/php4/Makefile.ext
+++ b/lang/php4/Makefile.ext
@@ -389,6 +389,9 @@ CONFIGURE_ARGS+=--without-cdb
. endif
. if defined(WITH_DB4)
WITH_DB4_VER?= 41
+. if ${WITH_DB4_VER} == 43
+LIB_DEPENDS+= db-4.3.0:${PORTSDIR}/databases/db43
+. else
. if ${WITH_DB4_VER} == 42
LIB_DEPENDS+= db-4.2.2:${PORTSDIR}/databases/db42
. else
@@ -398,6 +401,7 @@ LIB_DEPENDS+= db4.0:${PORTSDIR}/databases/db4
LIB_DEPENDS+= db41.1:${PORTSDIR}/databases/db41
. endif
. endif
+. endif
CONFIGURE_ARGS+=--with-db4=${LOCALBASE}
. endif
. if defined(WITH_GDBM)