aboutsummaryrefslogtreecommitdiffstats
path: root/lang/php5
diff options
context:
space:
mode:
Diffstat (limited to 'lang/php5')
-rw-r--r--lang/php5/Makefile8
-rw-r--r--lang/php5/files/patch-scripts::phpize.in4
2 files changed, 8 insertions, 4 deletions
diff --git a/lang/php5/Makefile b/lang/php5/Makefile
index 03aa163deecd..889a4bba2283 100644
--- a/lang/php5/Makefile
+++ b/lang/php5/Makefile
@@ -7,7 +7,7 @@
PORTNAME= php5
PORTVERSION= 5.3.3
-PORTREVISION?= 1
+PORTREVISION?= 2
CATEGORIES?= lang devel www
MASTER_SITES= ${MASTER_SITE_PHP}
MASTER_SITE_SUBDIR= distributions
@@ -21,7 +21,7 @@ LATEST_LINK= ${PKGNAMEPREFIX}${PORTNAME}${PKGNAMESUFFIX}
USE_BZIP2= yes
MAKE_JOBS_SAFE= yes
.if !defined(PKGNAMESUFFIX)
-USE_AUTOTOOLS= autoconf:262
+USE_AUTOTOOLS= autoconf:267
LIB_DEPENDS= pcre.0:${PORTSDIR}/devel/pcre
@@ -167,7 +167,11 @@ post-patch:
${WRKSRC}/sapi/fpm/php-fpm.conf.in
.endif
+# Work around issues with newer (>=2.64) autoconf
pre-configure:
+ @${REINPLACE_CMD} -E 's:^((m4_)?divert)[(]([0-9]*)[)]:\1(600\3):' \
+ ${WRKSRC}/configure.in `${FIND} ${WRKSRC} -name '*.m4'`
+ @${RM} ${WRKSRC}/configure
@${CAT} ${WRKSRC}/acinclude.m4 ${WRKSRC}/build/libtool.m4 > ${WRKSRC}/aclocal.m4
post-build:
diff --git a/lang/php5/files/patch-scripts::phpize.in b/lang/php5/files/patch-scripts::phpize.in
index 8d3afdbecc08..bbac86ce30ef 100644
--- a/lang/php5/files/patch-scripts::phpize.in
+++ b/lang/php5/files/patch-scripts::phpize.in
@@ -6,8 +6,8 @@
{
- test -z "$PHP_AUTOCONF" && PHP_AUTOCONF=autoconf
- test -z "$PHP_AUTOHEADER" && PHP_AUTOHEADER=autoheader
-+ test -z "$PHP_AUTOCONF" && PHP_AUTOCONF=autoconf-2.62
-+ test -z "$PHP_AUTOHEADER" && PHP_AUTOHEADER=autoheader-2.62
++ test -z "$PHP_AUTOCONF" && PHP_AUTOCONF=autoconf-2.67
++ test -z "$PHP_AUTOHEADER" && PHP_AUTOHEADER=autoheader-2.67
if test ! -x "`$php_shtool path $PHP_AUTOCONF`"; then
cat <<EOF