aboutsummaryrefslogtreecommitdiffstats
path: root/lang/python32/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'lang/python32/Makefile')
-rw-r--r--lang/python32/Makefile12
1 files changed, 4 insertions, 8 deletions
diff --git a/lang/python32/Makefile b/lang/python32/Makefile
index 970afaecc195..05c2793052f5 100644
--- a/lang/python32/Makefile
+++ b/lang/python32/Makefile
@@ -6,6 +6,7 @@
PORTNAME= python25
PORTVERSION= 2.5.1
+PORTREVISION= 1
CATEGORIES= lang python ipv6
MASTER_SITES= ${PYTHON_MASTER_SITES}
MASTER_SITE_SUBDIR= ${PYTHON_MASTER_SITE_SUBDIR}
@@ -38,6 +39,9 @@ PLIST_SUB= PYVER=${PYTHON_VERSION:S/python//} \
DEMODIR= ${PREFIX}/share/examples/${PYTHON_VERSION}
TOOLSDIR= ${PREFIX}/share/${PYTHON_VERSION}
+PLATFORMS= plat-freebsd4 plat-freebsd5 plat-freebsd6 \
+ plat-freebsd7 plat-freebsd8
+
BIN_SCRIPTS= idle pydoc python python-shared smtpd.py python-config \
python-shared-config
BINLINKS_SUB= -e 's,smtpd,smtpd${PYTHON_VER},' \
@@ -116,14 +120,6 @@ CONFIGURE_ARGS+= --disable-ipv6
CONFIGURE_ARGS+= --with-fpectl
.endif
-.if ${OSVERSION} >= 700000
-PLATFORMS=plat-freebsd4 plat-freebsd5 plat-freebsd6
-.elif ${OSVERSION} >= 600000
-PLATFORMS=plat-freebsd4 plat-freebsd5 plat-freebsd7
-.else
-PLATFORMS=plat-freebsd4 plat-freebsd6 plat-freebsd7
-.endif
-
pre-patch:
${MKDIR} ${WRKSRC} ${SHARED_WRKSRC}/Modules
${SED} -e '1s,^.*$$,#!${PREFIX}/bin/${PYTHON_VERSION},' \