aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
Diffstat (limited to 'lang')
-rw-r--r--lang/ecl/Makefile8
-rw-r--r--lang/harbour/Makefile8
-rw-r--r--lang/mosml/Makefile6
-rw-r--r--lang/newlisp-devel/Makefile6
-rw-r--r--lang/qore/Makefile12
-rw-r--r--lang/racket-minimal/Makefile6
6 files changed, 28 insertions, 18 deletions
diff --git a/lang/ecl/Makefile b/lang/ecl/Makefile
index 0e2579e4c3d5..6a9aa6e54671 100644
--- a/lang/ecl/Makefile
+++ b/lang/ecl/Makefile
@@ -12,10 +12,12 @@ COMMENT= ANSI Common Lisp implementation
LICENSE= LGPL20
-LIB_DEPENDS= libgmp.so:math/gmp
+BROKEN_aarch64= fails to compile: error: unknown type name AO_TS_t
+BROKEN_mips= fails to build: qemu: uncaught target signal 11 (Segmentation fault) - core dumped
+BROKEN_mips64= fails to build: qemu: uncaught target signal 11 (Segmentation fault) - core dumped
+BROKEN_powerpc64= fails to link: undefined reference to fmodl
-BROKEN_aarch64= Does not compile: error: unknown type name AO_TS_t
-BROKEN_powerpc64= Does not link: undefined reference to fmodl
+LIB_DEPENDS= libgmp.so:math/gmp
MAKE_JOBS_UNSAFE= yes
USES= gmake perl5 tar:tgz
diff --git a/lang/harbour/Makefile b/lang/harbour/Makefile
index e2356533cf45..58e55e321c42 100644
--- a/lang/harbour/Makefile
+++ b/lang/harbour/Makefile
@@ -10,14 +10,16 @@ MASTER_SITES= SF/${PORTNAME}-project/source/${PORTVERSION}
MAINTAINER= m.tsatsenko@gmail.com
COMMENT= Open source Clipper-compatible compiler
+BROKEN_mips= does not build: clang: Command not found
+BROKEN_mips64= does not build: clang: Command not found
+BROKEN_powerpc64= does not build: clang: Command not found
+BROKEN_sparc64= does not compile: assertion failed
+
LIB_DEPENDS= libslang.so:devel/libslang2\
libpcre.so:devel/pcre
BUILD_DEPENDS= bash:shells/bash
RUN_DEPENDS:= ${BUILD_DEPENDS}
-BROKEN_powerpc64= does not build: clang: Command not found
-BROKEN_sparc64= does not compile on sparc64: assertion failed
-
PORTDOCS= *.txt *.hbd NEWS INSTALL TODO COPYING ChangeLog
USES= bison gmake shebangfix ssl
diff --git a/lang/mosml/Makefile b/lang/mosml/Makefile
index 4e1e889359b5..8ae92334c479 100644
--- a/lang/mosml/Makefile
+++ b/lang/mosml/Makefile
@@ -9,14 +9,16 @@ CATEGORIES= lang
MAINTAINER= johans@FreeBSD.org
COMMENT= Lightweight implementation of Standard ML
+BROKEN_mips= does not configure: this architecture seems to be neither big endian nor little endian
+BROKEN_mips64= does not configure: this architecture seems to be neither big endian nor little endian
+BROKEN_powerpc64= does not configure: this architecture seems to be neither big endian nor little endian
+
LIB_DEPENDS= libgmp.so:math/gmp \
libgdbm.so:databases/gdbm
GH_ACCOUNT= kfl
USE_GITHUB= yes
-BROKEN_powerpc64= does not configure: this architecture seems to be neither big endian nor little endian
-
RESTRICTED= Restrictions on for-profit distribution
USES= compiler:features gmake perl5
diff --git a/lang/newlisp-devel/Makefile b/lang/newlisp-devel/Makefile
index 12c4e79536f0..5a288c72ac1c 100644
--- a/lang/newlisp-devel/Makefile
+++ b/lang/newlisp-devel/Makefile
@@ -13,9 +13,11 @@ COMMENT= LISP like scripting language
LICENSE= GPLv3
-LIB_DEPENDS= libffi.so:devel/libffi
+BROKEN_mips= fails to compile: unrecognized command line option "-m64"
+BROKEN_mips64= fails to compile: unrecognized command line option "-m64"
+BROKEN_powerpc64= fails to build: error: redefinition of typedef CPPFunction
-BROKEN_powerpc64= does not build: error: redefinition of typedef CPPFunction
+LIB_DEPENDS= libffi.so:devel/libffi
CONFLICTS= newlisp-[0-9]*
diff --git a/lang/qore/Makefile b/lang/qore/Makefile
index 95af56be0876..fc61f2903652 100644
--- a/lang/qore/Makefile
+++ b/lang/qore/Makefile
@@ -10,17 +10,19 @@ COMMENT= Qore Programming Language
LICENSE= MIT
+BROKEN_armv6= fails to compile: calling a private constructor of class 'ReferenceNode'
+BROKEN_armv7= fails to compile: calling a private constructor of class 'ReferenceNode'
+BROKEN_mips= fails to link: single-compilation-unit.cpp:(.text+0xdfc): relocation truncated to fit: R_MIPS_CALL16 against '__ltdf2@@FBSDprivate_1.0'
+BROKEN_mips64= fails to link: single-compilation-unit.cpp:(.text+0xdfc): relocation truncated to fit: R_MIPS_CALL16 against '__ltdf2@@FBSDprivate_1.0'
+BROKEN_powerpc= fails to build
+BROKEN_powerpc64= fails to compile: unsupported relocation against r1
+
LIB_DEPENDS= libpcre.so:devel/pcre \
libmpfr.so:math/mpfr
BUILD_DEPENDS= ${LOCALBASE}/bin/flex:textproc/flex \
${LOCALBASE}/bin/bison:devel/bison \
${LOCALBASE}/bin/bash:shells/bash
-BROKEN_armv6= fails to compile: calling a private constructor of class 'ReferenceNode'
-BROKEN_armv7= fails to compile: calling a private constructor of class 'ReferenceNode'
-BROKEN_powerpc= fails to build
-BROKEN_powerpc64= fails to compile: unsupported relocation against r1
-
USES= gmake iconv libtool:build pathfix autoreconf ssl
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
diff --git a/lang/racket-minimal/Makefile b/lang/racket-minimal/Makefile
index 7fb5b7225cef..7d4a2b280097 100644
--- a/lang/racket-minimal/Makefile
+++ b/lang/racket-minimal/Makefile
@@ -19,15 +19,15 @@ COMMENT= Interactive, integrated, graphical Scheme programming environment
LICENSE= LGPL3
-LIB_DEPENDS= libffi.so:devel/libffi
-
BROKEN_armv6= fails to compile: ./lightning/lightning.h:81:2: error: GNU lightning does not support the current target
BROKEN_armv7= fails to compile: ./lightning/lightning.h:81:2: error: GNU lightning does not support the current target
BROKEN_i386= fails to build: Seg fault (internal error) at 0x606060a
BROKEN_powerpc64= fails to build: jit.c: 'JIT_LOCAL4' undeclared (first use in this function)
-NOT_FOR_ARCHS= aarch64 aarch64 sparc64
+NOT_FOR_ARCHS= aarch64 aarch64 mips mips64 sparc64
NOT_FOR_ARCHS_REASON= not yet ported to this arch
+LIB_DEPENDS= libffi.so:devel/libffi
+
MAKE_JOBS_UNSAFE=yes
CONFLICTS= racket-[0-9]*