aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
Diffstat (limited to 'lang')
-rw-r--r--lang/php4/Makefile2
-rw-r--r--lang/php5/Makefile2
-rw-r--r--lang/php53/Makefile2
3 files changed, 3 insertions, 3 deletions
diff --git a/lang/php4/Makefile b/lang/php4/Makefile
index 5e7ba24a4227..a94ea55f8d5d 100644
--- a/lang/php4/Makefile
+++ b/lang/php4/Makefile
@@ -310,7 +310,7 @@ CONFIGURE_ARGS+=--with-gd \
--with-jpeg-dir=${LOCALBASE} \
--with-png-dir=${LOCALBASE}
.if !defined(WITHOUT_X11)
-LIB_DEPENDS+= Xpm.4:${PORTSDIR}/x11/XFree86-4-libraries
+USE_XPM= yes
CONFIGURE_ARGS+=--with-xpm-dir=${X11BASE}
.endif
.if defined(WITH_LZW)
diff --git a/lang/php5/Makefile b/lang/php5/Makefile
index ee6cec5d54aa..037c5e2ea89f 100644
--- a/lang/php5/Makefile
+++ b/lang/php5/Makefile
@@ -297,7 +297,7 @@ CONFIGURE_ARGS+=--with-gd \
--with-jpeg-dir=${LOCALBASE} \
--with-png-dir=${LOCALBASE}
.if !defined(WITHOUT_X11)
-LIB_DEPENDS+= Xpm.4:${PORTSDIR}/x11/XFree86-4-libraries
+USE_XPM= yes
CONFIGURE_ARGS+=--with-xpm-dir=${X11BASE}
.endif
.if defined(WITH_LZW)
diff --git a/lang/php53/Makefile b/lang/php53/Makefile
index ee6cec5d54aa..037c5e2ea89f 100644
--- a/lang/php53/Makefile
+++ b/lang/php53/Makefile
@@ -297,7 +297,7 @@ CONFIGURE_ARGS+=--with-gd \
--with-jpeg-dir=${LOCALBASE} \
--with-png-dir=${LOCALBASE}
.if !defined(WITHOUT_X11)
-LIB_DEPENDS+= Xpm.4:${PORTSDIR}/x11/XFree86-4-libraries
+USE_XPM= yes
CONFIGURE_ARGS+=--with-xpm-dir=${X11BASE}
.endif
.if defined(WITH_LZW)