aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
Diffstat (limited to 'lang')
-rw-r--r--lang/nesasm/Makefile9
1 files changed, 4 insertions, 5 deletions
diff --git a/lang/nesasm/Makefile b/lang/nesasm/Makefile
index 69c339f38395..4d6d873a83b3 100644
--- a/lang/nesasm/Makefile
+++ b/lang/nesasm/Makefile
@@ -19,14 +19,13 @@ post-patch: .SILENT
-e '/^CFLAGS/{s/=/+=/;s/-O2//;}' \
${WRKSRC}/Makefile.unix
-NO_STAGE= yes
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/nesasm ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/nesasm ${STAGEDIR}${PREFIX}/bin
.ifndef(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}../documentation/*.txt ${DOCSDIR}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}../documentation/*.txt ${STAGEDIR}${DOCSDIR}
# The next install will overwrite readme.txt with a newer readme.txt
- ${INSTALL_DATA} ${WRKSRC}../readme.txt ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}../readme.txt ${STAGEDIR}${DOCSDIR}
.endif
.include <bsd.port.mk>