aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
Diffstat (limited to 'lang')
-rw-r--r--lang/hiphop-php/Makefile4
-rw-r--r--lang/sdcc/Makefile1
2 files changed, 4 insertions, 1 deletions
diff --git a/lang/hiphop-php/Makefile b/lang/hiphop-php/Makefile
index a819fb65cc93..da843f284164 100644
--- a/lang/hiphop-php/Makefile
+++ b/lang/hiphop-php/Makefile
@@ -3,7 +3,7 @@
PORTNAME= hiphop-php
PORTVERSION= 0.0.20120716
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= lang devel www
MASTER_SITES= https://github.com/facebook/hiphop-php/tarball/${GITVERSION}/:main \
http://unicode.org/Public/UNIDATA/:unidata \
@@ -32,6 +32,8 @@ LICENSE_DISTFILES_UNICODE= EastAsianWidth.txt \
8859-11.TXT 8859-13.TXT 8859-14.TXT 8859-15.TXT 8859-16.TXT
LICENSE_DISTFILES_ZEND200= ${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX}
+BROKEN= Does not build with recent boost
+
LIB_DEPENDS= icudata:${PORTSDIR}/devel/icu \
boost_thread:${PORTSDIR}/devel/boost-libs \
execinfo:${PORTSDIR}/devel/libexecinfo \
diff --git a/lang/sdcc/Makefile b/lang/sdcc/Makefile
index 994deaf4c79e..edd839051cbd 100644
--- a/lang/sdcc/Makefile
+++ b/lang/sdcc/Makefile
@@ -23,6 +23,7 @@ CONFLICTS_INSTALL= sdcc-[0-9]*
GNU_CONFIGURE= yes
USE_BZIP2= yes
USE_GMAKE= yes
+USE_GCC= 4.6+
OPTIONS_DEFINE= DEVLIB DOCS HC08 MCS51 PIC UCSIM Z80
OPTIONS_DEFAULT=${OPTIONS_DEFINE:NDOCS}