aboutsummaryrefslogtreecommitdiffstats
path: root/mail/pop3lite/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'mail/pop3lite/Makefile')
-rw-r--r--mail/pop3lite/Makefile10
1 files changed, 8 insertions, 2 deletions
diff --git a/mail/pop3lite/Makefile b/mail/pop3lite/Makefile
index 2c2a619e2769..9eca8273735e 100644
--- a/mail/pop3lite/Makefile
+++ b/mail/pop3lite/Makefile
@@ -7,7 +7,7 @@
PORTNAME= pop3lite
PORTVERSION= 0.2.4a
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= mail
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -15,14 +15,20 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
COMMENT= A flexible, modular RFC-compliant POP3 daemon
-USE_AUTOTOOLS= libtool:15
+USE_AUTOTOOLS= libtool:22 libltdl:22
USE_GNOME= glib12
USE_GMAKE= yes
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
MAN5= pop3lite.conf.5
MAN8= pop3lite.8
INFO= pop3lite-admin
+post-patch:
+ @${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|g' \
+ ${WRKSRC}/configure
+
.include <bsd.port.mk>