aboutsummaryrefslogtreecommitdiffstats
path: root/mail/postfix-gps/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'mail/postfix-gps/Makefile')
-rw-r--r--mail/postfix-gps/Makefile45
1 files changed, 0 insertions, 45 deletions
diff --git a/mail/postfix-gps/Makefile b/mail/postfix-gps/Makefile
deleted file mode 100644
index d63c0a4fcb9b..000000000000
--- a/mail/postfix-gps/Makefile
+++ /dev/null
@@ -1,45 +0,0 @@
-# Created by: Xin LI <delphij@FreeBSD.org>
-# $FreeBSD$
-
-PORTNAME= gps
-PORTVERSION= 1.005
-PORTREVISION= 6
-CATEGORIES= mail security
-MASTER_SITES= SF/greylist/greylist/${PORTVERSION}-bugfix
-PKGNAMEPREFIX= postfix-
-DISTNAME= gps-${PORTVERSION}-bugfix
-
-MAINTAINER= ports@FreeBSD.org
-COMMENT= Greylist Policy Service for postfix
-
-LIB_DEPENDS= libdbi.so:${PORTSDIR}/databases/libdbi
-RUN_DEPENDS= ${LOCALBASE}/lib/dbd:${PORTSDIR}/databases/libdbi-drivers \
- p5-DBD-mysql>=0:${PORTSDIR}/databases/p5-DBD-mysql
-
-SCRIPT_FILES= gps-maintain.pl gps-db-update.pl
-PLIST_FILES= etc/gps.conf-dist libexec/gps libexec/gps-maintain.pl libexec/gps-db-update.pl
-SUB_FILES= pkg-message
-
-WRKSRC= ${WRKDIR}/release-${PORTVERSION}
-
-USE_AUTOTOOLS= automake autoconf
-AUTOMAKE_ARGS= --add-missing
-CONFIGURE_ARGS= --bindir=${PREFIX}/libexec --includedir=${PREFIX}/include
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= ${PTHREAD_LIBS} -L${LOCALBASE}/lib
-CXXFLAGS+= -I${LOCALBASE}/include
-
-NO_STAGE= yes
-pre-configure:
- @cd ${WRKSRC} && ${ACLOCAL}
-
-post-install:
- @${INSTALL_DATA} ${WRKSRC}/etc/gps.conf ${PREFIX}/etc/gps.conf-dist
-.for f in ${SCRIPT_FILES}
- @${INSTALL_SCRIPT} ${WRKSRC}/${f} ${PREFIX}/libexec
-.endfor
-.if !defined(BATCH)
- @${CAT} ${PKGMESSAGE}
-.endif
-
-.include <bsd.port.mk>