aboutsummaryrefslogtreecommitdiffstats
path: root/mail/postgrey/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'mail/postgrey/Makefile')
-rw-r--r--mail/postgrey/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/mail/postgrey/Makefile b/mail/postgrey/Makefile
index 1b4564d67d9b..ee4f2cbd5828 100644
--- a/mail/postgrey/Makefile
+++ b/mail/postgrey/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= postgrey
-PORTVERSION= 1.18
+PORTVERSION= 1.21
CATEGORIES= mail
MASTER_SITES= http://isg.ee.ethz.ch/tools/postgrey/pub/
@@ -19,6 +19,7 @@ RUN_DEPENDS= ${SITE_PERL}/Net/Server.pm:${PORTSDIR}/net/p5-Net-Server \
USE_PERL5= yes
USE_RC_SUBR= yes
+USE_REINPLACE= yes
NO_BUILD= yes
ETCFILES= whitelist_clients whitelist_recipients
@@ -52,6 +53,9 @@ pre-extract:
IGNORE= Needs perl 5.6.1 or higher, install lang/perl5.8 and try again
.endif
+post-patch:
+ ${REINPLACE_CMD} -e "s#/etc/#${PREFIX}/etc/#" ${WRKSRC}/postgrey
+
pre-install:
${SED} -e 's#%%PREFIX%%#${PREFIX}#g' -e 's#%%RC_SUBR%%#${RC_SUBR}#g' \
${FILESDIR}/postgrey.sh > ${WRKDIR}/postgrey.sh