aboutsummaryrefslogtreecommitdiffstats
path: root/mail/prepflog/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'mail/prepflog/Makefile')
-rw-r--r--mail/prepflog/Makefile11
1 files changed, 6 insertions, 5 deletions
diff --git a/mail/prepflog/Makefile b/mail/prepflog/Makefile
index 916698ccdb54..b4f8a105f7cf 100644
--- a/mail/prepflog/Makefile
+++ b/mail/prepflog/Makefile
@@ -10,13 +10,14 @@ EXTRACT_SUFX= .tgz
MAINTAINER= tabmow@freenode.net
COMMENT= Prepares logfiles in a sanitised format for pflogsumm and awstats
-PLIST_FILES= bin/prepflog
-
+USES= perl5 shebangfix
NO_BUILD= yes
-USES= perl5
-NO_STAGE= yes
+SHEBANG_FILES= prepflog.pl
+PLIST_FILES= bin/prepflog
+
do-install:
- ${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME}.pl ${PREFIX}/bin/${PORTNAME}
+ ${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME}.pl \
+ ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
.include <bsd.port.mk>