aboutsummaryrefslogtreecommitdiffstats
path: root/mail/py-mail-parser/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'mail/py-mail-parser/Makefile')
-rw-r--r--mail/py-mail-parser/Makefile23
1 files changed, 23 insertions, 0 deletions
diff --git a/mail/py-mail-parser/Makefile b/mail/py-mail-parser/Makefile
new file mode 100644
index 000000000000..b9808ad9aa26
--- /dev/null
+++ b/mail/py-mail-parser/Makefile
@@ -0,0 +1,23 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= mail-parser
+PORTVERSION= 3.9.1
+CATEGORIES= mail python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Wrapper for email standard library
+
+LICENSE= APACHE20
+
+RUN_DEPENDS= msgconvert:mail/p5-Email-Outlook-Message \
+ ${PY_IPADDRESS} \
+ ${PYTHON_PKGNAMEPREFIX}simplejson>=0:devel/py-simplejson@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}six>=0:devel/py-six@${PY_FLAVOR}
+
+USES= python
+USE_PYTHON= autoplist concurrent distutils
+
+.include <bsd.port.mk>