aboutsummaryrefslogtreecommitdiffstats
path: root/mail/qmail/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'mail/qmail/Makefile')
-rw-r--r--mail/qmail/Makefile10
1 files changed, 9 insertions, 1 deletions
diff --git a/mail/qmail/Makefile b/mail/qmail/Makefile
index 87457d593dbe..bb586175932f 100644
--- a/mail/qmail/Makefile
+++ b/mail/qmail/Makefile
@@ -165,7 +165,8 @@ OPTIONS+= TLS "SMTP TLS support" on \
AUTOHOMEDIRMAKE "auto-homedir-make feature" on \
LDAP_DEBUG "possibility to log and debug imap/pop" off \
SMTPEXTFORK "Allow qmail-smtpd fork external progs" off \
- XF_QUITASAP "Close SMTP session ASAP (SMTPEXTFORK)" off
+ XF_QUITASAP "Close SMTP session ASAP (SMTPEXTFORK)" off \
+ SENDERCHECK4 "LOOSE checks exclusively for RELAY clients" off
LDAP_PARAMS= ALTQUEUE BIGBROTHER BIGTODO BIND_8_COMPAT\
CLEARTEXTPASSWD DASH_EXT DATA_COMPRESS\
@@ -477,6 +478,13 @@ DISTFILES+= ${SMTPEXTFORK_PATCH:S/$/:extfork/} \
README.smtpextfork:extfork
.endif
+.if defined(SLAVE_LDAP)
+PATCH_SITES+= http://www6.freebsdbrasil.com.br/~eksffa/l/dev/qmail/:sendercheck4 \
+ ${MASTER_SITE_LOCAL:S/$/:sendercheck4/}
+PATCH_SITE_SUBDIR+= garga/qmail/:sendercheck4
+PATCHFILES+= qmail-ldap-1.03_qmail-smtpd_SENDERCHECK4.patch:sendercheck4
+.endif
+
# Some default values, these can be modified by make command line
.if defined(WITH_BIG_CONCURRENCY_PATCH) && !defined(BARRIER_BIG_CONCURRENCY_PATCH)
WITH_BIG_CONCURRENCY_PATCH_CONCURRENCY_LIMIT?= 509