aboutsummaryrefslogtreecommitdiffstats
path: root/mail/rspamd-devel/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'mail/rspamd-devel/Makefile')
-rw-r--r--mail/rspamd-devel/Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/mail/rspamd-devel/Makefile b/mail/rspamd-devel/Makefile
index 89d0672ec0c8..f73c3b7bb85d 100644
--- a/mail/rspamd-devel/Makefile
+++ b/mail/rspamd-devel/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= rspamd
-PORTVERSION= 1.1.0.a.17122015
+PORTVERSION= 1.1.0.a1.30122015
CATEGORIES= mail
MASTER_SITES= http://rspamd.com/downloads/
PKGNAMESUFFIX= -devel
@@ -38,7 +38,8 @@ CMAKE_ARGS+= -DCONFDIR=${PREFIX}/etc/rspamd \
-DBUILD_PORT=yes \
-DFORCE_GMIME24=yes \
-DLIBDIR=${PREFIX}/lib/rspamd \
- -DNO_SHARED=ON
+ -DNO_SHARED=ON \
+ -DDEBUG=ON
USES= cmake:outsource gettext iconv pkgconfig tar:xz perl5 \
compiler:c11
@@ -48,6 +49,8 @@ USE_PERL5= build
USE_GNOME= glib20
USE_OPENSSL= yes
USE_SQLITE= yes
+DEBUG_FLAGS= -g -O0
+WITH_DEBUG= yes
.include <bsd.port.options.mk>