aboutsummaryrefslogtreecommitdiffstats
path: root/mail/turba/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'mail/turba/Makefile')
-rw-r--r--mail/turba/Makefile18
1 files changed, 9 insertions, 9 deletions
diff --git a/mail/turba/Makefile b/mail/turba/Makefile
index 5f055a74a0de..1b0c0017f37e 100644
--- a/mail/turba/Makefile
+++ b/mail/turba/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= turba
-PORTVERSION= 1.2
-PORTREVISION= 2
+PORTVERSION= 1.2.1
CATEGORIES= mail www
MASTER_SITES= ftp://ftp.horde.org/pub/turba/ \
ftp://ftp.au.horde.org/pub/horde/turba/ \
@@ -26,15 +25,11 @@ COMMENT= The Horde contact management application
#
#-----------------------------------------------------------------------
+RUN_DEPENDS= ${LOCALBASE}/www/horde/index.php:${PORTSDIR}/www/horde2
+
.if !defined(WITHOUT_LDAP)
-.if exists(${LOCALBASE}/lib/libldap.so.1)
-LIB_DEPENDS+= ldap.1:${PORTSDIR}/net/openldap12
-.else
-LIB_DEPENDS+= ldap.2:${PORTSDIR}/net/openldap21-client
+USE_OPENLDAP= yes
.endif
-.endif
-
-RUN_DEPENDS+= ${LOCALBASE}/www/horde/index.php:${PORTSDIR}/www/horde2
NO_BUILD= yes
USE_REINPLACE= yes
@@ -64,6 +59,11 @@ PHPSO= ${LOCALBASE}/libexec/apache2/libphp4.so
PHPSO= ${LOCALBASE}/libexec/apache/libphp4.so
.endif
+post-patch:
+ @${RM} ${WRKSRC}/config/conf.php.dist.orig \
+ ${WRKSRC}/config/prefs.php.dist.orig \
+ ${WRKSRC}/config/sources.php.dist.orig
+
pre-install:
.if !defined(WITHOUT_LDAP)
.if exists(${LOCALBASE}/lib/libldap.so.1)