aboutsummaryrefslogtreecommitdiffstats
path: root/mail/xf-spf/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'mail/xf-spf/Makefile')
-rw-r--r--mail/xf-spf/Makefile36
1 files changed, 36 insertions, 0 deletions
diff --git a/mail/xf-spf/Makefile b/mail/xf-spf/Makefile
new file mode 100644
index 000000000000..dfa8e0b758f1
--- /dev/null
+++ b/mail/xf-spf/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: xf-spf
+# Date created: 2007-09-12
+# Whom: Felippe de Meirelles Motta <lippe@freebsdbrasil.com.br>
+#
+# $FreeBSD$
+#
+
+PORTNAME= xf-spf
+PORTVERSION= 0.2
+CATEGORIES= mail
+MASTER_SITES= http://www6.freebsdbrasil.com.br/~eksffa/l/dev/qmail-smtpextfork/
+
+MAINTAINER= lippe@freebsdbrasil.com.br
+COMMENT= SPF checker for Qmail's SMTPEXTFORK patch
+
+LIB_DEPENDS+= spf2.2:${PORTSDIR}/mail/libspf2
+
+USE_QMAIL= yes
+USE_BZIP2= yes
+
+SUB_FILES= pkg-message
+SUB_LIST= QMAIL_PREFIX=${QMAIL_PREFIX}
+PLIST_SUB= QMAIL_PREFIX=${QMAIL_PREFIX}
+
+PORTDOCS= README TODO CHANGELOG COPYRIGHT
+
+.include <bsd.port.pre.mk>
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ @${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${DOCSDIR}/
+.endif
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.post.mk>