aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
Diffstat (limited to 'mail')
-rw-r--r--mail/Makefile1
-rw-r--r--mail/php53-imap/Makefile14
-rw-r--r--mail/php53-imap/files/patch-config.m442
3 files changed, 57 insertions, 0 deletions
diff --git a/mail/Makefile b/mail/Makefile
index 5248ae55b93e..7cbdf19d9b89 100644
--- a/mail/Makefile
+++ b/mail/Makefile
@@ -487,6 +487,7 @@
SUBDIR += pgpsendmail
SUBDIR += php5-imap
SUBDIR += php52-imap
+ SUBDIR += php53-imap
SUBDIR += phplist
SUBDIR += phpmailer
SUBDIR += phpmailer2
diff --git a/mail/php53-imap/Makefile b/mail/php53-imap/Makefile
new file mode 100644
index 000000000000..73a165bc0e33
--- /dev/null
+++ b/mail/php53-imap/Makefile
@@ -0,0 +1,14 @@
+# New ports collection makefile for: php53-imap
+# Date created: 12 Apr 2012
+# Whom: Florian Smeets <flo@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+CATEGORIES= mail
+
+MASTERDIR= ${.CURDIR}/../../lang/php53
+
+PKGNAMESUFFIX= -imap
+
+.include "${MASTERDIR}/Makefile"
diff --git a/mail/php53-imap/files/patch-config.m4 b/mail/php53-imap/files/patch-config.m4
new file mode 100644
index 000000000000..ab7120b2c8c8
--- /dev/null
+++ b/mail/php53-imap/files/patch-config.m4
@@ -0,0 +1,42 @@
+--- config.m4.orig 2010-02-07 14:06:54.000000000 +0100
++++ config.m4 2010-03-08 11:56:24.000000000 +0100
+@@ -103,6 +103,8 @@
+ PHP_ARG_WITH(imap-ssl,for IMAP SSL support,
+ [ --with-imap-ssl[=DIR] IMAP: Include SSL support. DIR is the OpenSSL install prefix], no, no)
+
++PHP_ARG_WITH(pcre-dir, pcre install prefix,
++[ --with-pcre-dir IMAP: pcre install prefix], no, no)
+
+ if test "$PHP_IMAP" != "no"; then
+ PHP_SUBST(IMAP_SHARED_LIBADD)
+@@ -119,6 +121,30 @@
+ fi
+ done
+
++ dnl This is PECL build, check if bundled PCRE library is used
++ old_CPPFLAGS=$CPPFLAGS
++ CPPFLAGS=$INCLUDES
++ AC_EGREP_CPP(yes,[
++#include <main/php_config.h>
++#if defined(HAVE_BUNDLED_PCRE) && !defined(COMPILE_DL_PCRE)
++yes
++#endif
++ ],[
++ PHP_PCRE_REGEX=yes
++ ],[
++ AC_EGREP_CPP(yes,[
++#include <main/php_config.h>
++#if defined(HAVE_PCRE) && !defined(COMPILE_DL_PCRE)
++yes
++#endif
++ ],[
++ PHP_PCRE_REGEX=pecl
++ PHP_ADD_INCLUDE($PHP_PCRE_DIR/include)
++ ],[
++ PHP_PCRE_REGEX=no
++ ])
++ ])
++
+ dnl Check for c-client version 2004
+ AC_EGREP_HEADER(mail_fetch_overview_sequence, $IMAP_INC_DIR/mail.h, [
+ AC_DEFINE(HAVE_IMAP2004,1,[ ])