aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
Diffstat (limited to 'mail')
-rw-r--r--mail/mutt-devel/Makefile8
-rw-r--r--mail/mutt-devel/scripts/generate-plist5
2 files changed, 13 insertions, 0 deletions
diff --git a/mail/mutt-devel/Makefile b/mail/mutt-devel/Makefile
index ef0be54f0e46..ad582879aae2 100644
--- a/mail/mutt-devel/Makefile
+++ b/mail/mutt-devel/Makefile
@@ -175,7 +175,9 @@ SGML_USED= no
SGML_USED= no
.endif
+.if !defined(WITHOUT_NLS)
LIB_DEPENDS= intl.5:${PORTSDIR}/devel/gettext
+.endif
.if defined(NOPORTDOCS)
SGML_USED= no
@@ -216,6 +218,9 @@ CONFIGURE_ARGS+= --with-slang=${PREFIX}
.if defined(WITH_MUTT_CYRUS_SASL)
CONFIGURE_ARGS+= --with-sasl=${LOCALBASE}
.endif
+.if defined(WITHOUT_NLS)
+CONFIGURE_ARGS+= --disable-nls
+.endif
PATCH_DIST_STRIP= -p1
@@ -292,6 +297,9 @@ SCRIPTS_ENV+= MUTT_PGP_PATCH="yes"
.if ! defined(WITHOUT_MUTT_HTML)
SCRIPTS_ENV+= MUTT_HTML="yes"
.endif
+.if !defined(WITHOUT_NLS)
+SCRIPTS_ENV+= MUTT_NLS="yes"
+.endif
.if !defined(NOPORTDOCS)
SCRIPTS_ENV+= MUTT_PORTDOCS="yes"
diff --git a/mail/mutt-devel/scripts/generate-plist b/mail/mutt-devel/scripts/generate-plist
index 951219d63d78..bcd2796e07da 100644
--- a/mail/mutt-devel/scripts/generate-plist
+++ b/mail/mutt-devel/scripts/generate-plist
@@ -31,6 +31,10 @@ bin/smime_keys
@unexec if cmp -s %D/etc/Muttrc.dist %D/etc/Muttrc; then rm -f %D/etc/Muttrc; fi
etc/Muttrc.dist
etc/mime.types
+EOF
+
+if [ "$MUTT_NLS" = "yes" ]; then
+ cat >> $tmp_first <<EOF
share/locale/bg/LC_MESSAGES/mutt.mo
share/locale/ca/LC_MESSAGES/mutt.mo
share/locale/cs/LC_MESSAGES/mutt.mo
@@ -59,6 +63,7 @@ share/locale/uk/LC_MESSAGES/mutt.mo
share/locale/zh_CN/LC_MESSAGES/mutt.mo
share/locale/zh_TW/LC_MESSAGES/mutt.mo
EOF
+fi
if [ "$MUTT_PORTDOCS" = "yes" ]; then
cat >> $tmp_first <<EOF