aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
Diffstat (limited to 'mail')
-rw-r--r--mail/lens/Makefile25
-rw-r--r--mail/lens/pkg-descr3
2 files changed, 12 insertions, 16 deletions
diff --git a/mail/lens/Makefile b/mail/lens/Makefile
index d3513719148b..efc198e7c062 100644
--- a/mail/lens/Makefile
+++ b/mail/lens/Makefile
@@ -9,7 +9,7 @@ MASTER_SITES= http://www.pitecan.com/Lens/ \
${MASTER_SITE_LOCAL:S|%SUBDIR%|tota/lens|}
MAINTAINER= tota@FreeBSD.org
-COMMENT= A mail filter written in Ruby
+COMMENT= Mail filter written in Ruby
NO_BUILD= yes
USE_RUBY= yes
@@ -17,21 +17,18 @@ USE_RUBY= yes
LIB_FILES= lens.rb maildir.rb message.rb parsedate.rb classify.rb
RUBY_SHEBANG_FILES= lens
-NO_STAGE= yes
+OPTIONS_DEFINE= DOCS EXAMPLES
+
do-install:
- ${INSTALL_SCRIPT} ${WRKSRC}/lens ${PREFIX}/bin
- ${MKDIR} ${RUBY_SITELIBDIR}/lens
+ ${INSTALL_SCRIPT} ${WRKSRC}/lens ${STAGEDIR}${PREFIX}/bin
+ @${MKDIR} ${STAGEDIR}${RUBY_SITELIBDIR}/lens
.for f in ${LIB_FILES}
- ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_SITELIBDIR}/lens
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${RUBY_SITELIBDIR}/lens
.endfor
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/index.html ${DOCSDIR}
-.endif
-.if !defined(NOPORTEXAMPLES)
- ${MKDIR} ${EXAMPLESDIR}
- ${INSTALL_DATA} ${WRKSRC}/lensrc.sample ${EXAMPLESDIR}/dot.lensrc
- ${INSTALL_DATA} ${WRKSRC}/commandmailrc.sample ${EXAMPLESDIR}/dot.commandmailrc
-.endif
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/index.html ${STAGEDIR}${DOCSDIR}
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/lensrc.sample ${STAGEDIR}${EXAMPLESDIR}/dot.lensrc
+ ${INSTALL_DATA} ${WRKSRC}/commandmailrc.sample ${STAGEDIR}${EXAMPLESDIR}/dot.commandmailrc
.include <bsd.port.mk>
diff --git a/mail/lens/pkg-descr b/mail/lens/pkg-descr
index 52330d6ab7d4..1cf5d4f29b26 100644
--- a/mail/lens/pkg-descr
+++ b/mail/lens/pkg-descr
@@ -1,5 +1,4 @@
Lens is a mail filter written in Ruby. Lens can filter an
incoming mail when it is received and filter mails in a Maildir.
-Author: Toshiyuki Masui
-WWW: http://www.pitecan.com/Lens/
+WWW: http://www.pitecan.com/Lens/